This duplicates another bug already reported in our system: EXTJS-9259
  1. #1
    Sencha Premium Member
    Join Date
    Jan 2008
    Location
    Denmark
    Posts
    9
    Vote Rating
    0
    iver25 is on a distinguished road

      0  

    Default about:blank urls in extjs 4.2

    about:blank urls in extjs 4.2


    I have just migrated my project from extjs 4.0 to 4.2.

    And for some reason, I now get security problems when getting images from the default gray theme css. I should mention that the app has to run in https.

    When i debug in IE 8, I can see that the problem is the about:blank..... URL's in the css. The result is that for example my buttons don't get a background, or a border. There is no way to see it's a button.

    That is of course not acceptable for the user.

    Does anybody have an idea how I get IE 8 to use the correct images?

    I should mention that I have used Sencha Cmd 3.1.0.239 to build the project.

  2. #2
    Sencha - Senior Software Engineer mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    38,048
    Vote Rating
    994
    mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute

      0  

    Default


    I'm actually going to open a bug for this.
    Mitchell Simoens @SenchaMitch
    Sencha Inc, Senior Software Engineer
    ________________
    Check out my GitHub, lots of nice things for Ext JS 4 and Sencha Touch 2
    https://github.com/mitchellsimoens

    Think my support is good? Get more personalized support via a support subscription. https://www.sencha.com/store/

    Need more help with your app? Hire Sencha Services services@sencha.com

    Want to learn Sencha Touch 2? Check out Sencha Touch in Action that is in print!

    When posting code, please use BBCode's CODE tags.

  3. #3
    Sencha User
    Join Date
    Jul 2009
    Posts
    1
    Vote Rating
    0
    reece is on a distinguished road

      0  

    Default


    I can confirm this too.

    The following appears in all CSS files found in "resources/ext-theme-xxx/...":

    Code:
    background-image:("about:blank#...")
    When do you think there'll be a fix for this available?

  4. #4
    Sencha Premium Member
    Join Date
    Jan 2008
    Location
    Denmark
    Posts
    9
    Vote Rating
    0
    iver25 is on a distinguished road

      0  

    Default


    Has anybody found a fix for this?

    When can we expect a solution to this critical error?

  5. #5
    Sencha User
    Join Date
    Mar 2011
    Posts
    49
    Vote Rating
    6
    phani.gutha is on a distinguished road

      0  

    Default


    Hi All,
    Am also facing the same issue.
    is there any permanent solution or work around for this ?

  6. #6
    Sencha User Daniil's Avatar
    Join Date
    Jun 2010
    Location
    Saint-Petersburg, Russia
    Posts
    983
    Vote Rating
    116
    Daniil is a name known to all Daniil is a name known to all Daniil is a name known to all Daniil is a name known to all Daniil is a name known to all Daniil is a name known to all

      0  

    Default


    Hi,

    I think it is fixed in 4.2.1 beta. Here are some details.
    http://www.sencha.com/forum/showthre...165#post960993
    Object.NET
    Frameworks and Tools for .NET Developers
    --------------------------------------------------
    Ext.NET - Ext JS for ASP.NET - Examples | Twitter
    Bridge.NET - Launching Soon!
    --------------------------------------------------

  7. #7
    Sencha User
    Join Date
    Mar 2011
    Posts
    49
    Vote Rating
    6
    phani.gutha is on a distinguished road

      1  

    Default Got Solution / Work around

    Got Solution / Work around


    Hi Daniil,
    i tried to fix this, finally acheived it. please find the details in below link
    http://www.walkingtree.in/forums/showthread.php?1261-Extjs-4-2-neptune-theme-in-htpps-not-working-properly



  8. #8
    Sencha User Daniil's Avatar
    Join Date
    Jun 2010
    Location
    Saint-Petersburg, Russia
    Posts
    983
    Vote Rating
    116
    Daniil is a name known to all Daniil is a name known to all Daniil is a name known to all Daniil is a name known to all Daniil is a name known to all Daniil is a name known to all

      0  

    Default


    Interesting. Thank you for sharing!
    Object.NET
    Frameworks and Tools for .NET Developers
    --------------------------------------------------
    Ext.NET - Ext JS for ASP.NET - Examples | Twitter
    Bridge.NET - Launching Soon!
    --------------------------------------------------

  9. #9
    Sencha User Daniil's Avatar
    Join Date
    Jun 2010
    Location
    Saint-Petersburg, Russia
    Posts
    983
    Vote Rating
    116
    Daniil is a name known to all Daniil is a name known to all Daniil is a name known to all Daniil is a name known to all Daniil is a name known to all Daniil is a name known to all

      0  

    Default


    Hi Mitchell,

    The thread is still [OPEN]. Is it not fixed indeed? Seems, it is OK with 4.2.1 beta or are you facing any other issues regarding this?
    Object.NET
    Frameworks and Tools for .NET Developers
    --------------------------------------------------
    Ext.NET - Ext JS for ASP.NET - Examples | Twitter
    Bridge.NET - Launching Soon!
    --------------------------------------------------

  10. #10
    Sencha User
    Join Date
    May 2013
    Posts
    24
    Vote Rating
    0
    Roomy is on a distinguished road

      0  

    Default "Do you want to view only the webpage content that was delivered securely"?

    "Do you want to view only the webpage content that was delivered securely"?


    I am using gray theme, and having the same security warning on each web page.
    Is it due to blank URL or any other issue.
    And please tell me its solved or not?

    Please suggest the cause and solution.

    Thanks
    Last edited by Roomy; 8 Aug 2013 at 10:31 PM. Reason: Update