You found a bug! We've classified it as SDKTOOLS-387 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #1
    Ext JS Premium Member
    Join Date
    Oct 2010
    Posts
    5
    Vote Rating
    0
    wdmarin is on a distinguished road

      0  

    Default Cmd Build Failed: Failed to find file for @packageOverrides

    Cmd Build Failed: Failed to find file for @packageOverrides


    Using:
    Touch 2.1.1
    Sencha Architect 2.2.0 build 908
    Sencha Cmd v3.0.2.288

    While creating a production or testing build of a touch 2.1 app, I receive the error:
    Code:
    Failed to find file for @packageOverrides
    Does anyone know what that error means?

    The full error is:
    Code:
    [INF]           Processing class inheritance graph[INF]           Processing instantiation refereces to classes and aliases
    [INF]           Processing source dependencies
    [ERR]           Failed to find file for @packageOverrides
     required by C:\Users\David\Documents\Visual Studio 2012\Projects\DailyPaintworksSolution\DailyPaintworks.Web\mobile-dev\test\app.js
    [ERR]
    [ERR]           BUILD FAILED
    [ERR]           com.sencha.exceptions.BasicException: The following error occurred while executing this line:
    [ERR]           C:\Users\David\Documents\Visual Studio 2012\Projects\DailyPaintworksSolution\DailyPaintworks.Web\mobile-dev\test\.sencha\app\build-imp
    l.xml:137: com.sencha.exceptions.ExScript: Wrapped com.sencha.exceptions.BasicException: com.sencha.exceptions.ExBuild: Failed to find any files for @
    packageOverrides (x-app-build#273)   runAppBuild (x-app-build:273)   [anonymous] (x-app-build:545)   x_app_build (x-app-build:543)   <script> (anonymo
    us:1)
    [ERR]                   at com.sencha.exceptions.BasicException.wrap(BasicException.java:43)
    [ERR]                   at com.sencha.cli.Command.dispatch(Command.java:104)
    [ERR]                   at com.sencha.cli.Commands.dispatch(Commands.java:49)
    [ERR]                   at com.sencha.cli.AbstractCommand.dispatch(AbstractCommand.java:182)
    [ERR]                   at com.sencha.ant.SenchaCommandTask.doExecute(SenchaCommandTask.java:69)
    [ERR]                   at com.sencha.ant.BaseAntTask.execute(BaseAntTask.java:22)
    [ERR]                   at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
    [ERR]                   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    [ERR]                   at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    [ERR]                   at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    [ERR]                   at java.lang.reflect.Method.invoke(Unknown Source)
    [ERR]                   at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
    [ERR]                   at org.apache.tools.ant.Task.perform(Task.java:348)
    [ERR]                   at org.apache.tools.ant.Target.execute(Target.java:392)
    [ERR]                   at org.apache.tools.ant.Target.performTasks(Target.java:413)
    [ERR]                   at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
    [ERR]                   at org.apache.tools.ant.Project.executeTarget(Project.java:1368)
    [ERR]                   at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
    [ERR]                   at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
    [ERR]                   at com.sencha.ant.AntRunner.run(AntRunner.java:156)
    [ERR]                   at com.sencha.ant.AntRunner.run(AntRunner.java:72)
    [ERR]                   at com.sencha.command.BasePluginCommands$BasePluginCommand.run(BasePluginCommands.java:94)
    [ERR]                   at com.sencha.command.BasePluginCommands$BasePluginCommand.run(BasePluginCommands.java:98)
    [ERR]                   at com.sencha.command.BasePluginCommands$BaseNamePathCommand.run(BasePluginCommands.java:142)
    [ERR]                   at com.sencha.command.app.AppCommands$BuildCommand.execute(AppCommands.java:116)
    [ERR]                   at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    [ERR]                   at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    [ERR]                   at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    [ERR]                   at java.lang.reflect.Method.invoke(Unknown Source)
    [ERR]                   at com.sencha.cli.Command.dispatch(Command.java:78)
    [ERR]                   at com.sencha.cli.Commands.dispatch(Commands.java:49)
    [ERR]                   at com.sencha.cli.Commands.dispatch(Commands.java:49)
    [ERR]                   at com.sencha.command.Sencha.main(Sencha.java:71)
    I have been building the same app for a week without any issues. The same error occurs when I build a new empty application, as well.

    The only thing I did was to install a pushed update of Architect, which I have since replaced with the previous version.

    Update:

    I have found a work around. If I remove the line "//@require @packageOverrides" from the app.js file then the build works. Unfortunately Architect puts it back every time I save. So, it is a workaround but not a permanent solution. Perhaps it is also a clue to someone as to what is going on.

    Thank you!

    - David
    Last edited by wdmarin; 25 Mar 2013 at 5:22 AM. Reason: Added more information.

  2. #2
    Sencha - Ext JS Dev Team dongryphon's Avatar
    Join Date
    Jul 2009
    Location
    Kansas
    Posts
    1,512
    Vote Rating
    176
    dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of

      0  

    Default


    I will contact the Architect folks on this, but a better workaround would be to create any file and add this line to it:

    Code:
      //@tag packageOverrides
    That way the "//@require" directive will find something matching the tag name.
    Don Griffin
    Engineering Manager - Frameworks (Ext JS / Sencha Touch)

    Check the docs. Learn how to (properly) report a framework issue and a Sencha Cmd issue

    "Use the source, Luke!"

  3. #3
    Sencha - Ext JS Dev Team dongryphon's Avatar
    Join Date
    Jul 2009
    Location
    Kansas
    Posts
    1,512
    Vote Rating
    176
    dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of

      0  

    Default


    Also, just noticed, you might want to consider upgrading now that Sencha Cmd 3.1 is released.

    http://www.sencha.com/forum/showthre...-Now-Available
    Don Griffin
    Engineering Manager - Frameworks (Ext JS / Sencha Touch)

    Check the docs. Learn how to (properly) report a framework issue and a Sencha Cmd issue

    "Use the source, Luke!"

  4. #4
    Ext JS Premium Member
    Join Date
    Oct 2010
    Posts
    5
    Vote Rating
    0
    wdmarin is on a distinguished road

      0  

    Default Thank you...

    Thank you...


    Don,

    That is indeed a better workaround - thank you! I have upgraded Architect and Cmd to the latest and will wait to see what the Architect team has to say.

    Take care,

    - David

  5. #5
    Sencha - Ext JS Dev Team dongryphon's Avatar
    Join Date
    Jul 2009
    Location
    Kansas
    Posts
    1,512
    Vote Rating
    176
    dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of dongryphon has much to be proud of

      0  

    Default


    I have opened a bug in our bug tracker. This will be treated as a Cmd issue to resolve for 3.1.1

Thread Participants: 1

Tags for this Thread