You found a bug! We've classified it as SDKTOOLS-395 . We encourage you to continue the discussion and to find an acceptable workaround while we work on a permanent fix.
  1. #1
    Sencha Premium Member robert_k's Avatar
    Join Date
    Jun 2012
    Posts
    35
    Vote Rating
    1
    robert_k is on a distinguished road

      1  

    Question [ST2.1.1][CMD 3.1.0.256] Failed building SASS with system ruby

    [ST2.1.1][CMD 3.1.0.256] Failed building SASS with system ruby


    REQUIRED INFORMATION

    Sencha Cmd version(s) tested:
    • Sencha Cmd 3.1.0.256
    Operating System:
    • OS X 10.6.8
    Framework used:
    • Sencha Touch 2.1.1
    Description:
    • sencha app build testing
    • [INF] executing compass using system installed ruby runtime
    • error app.scss (Line 90: Invalid CSS after "}": expected selector or at-rule, was "%disclosure {")
    Steps to reproduce the problem:

    This error didn't happen with the last version of Sencha Cmd 3.0. I can manually go to my resources/sass directory and successfully run "compass compile" from there. It appears that Sencha Cmd is having trouble with @extend-only selectors.

    Just include a placeholder rule to your app.scss:

    Code:
    %shared {
      color: blue;
    }
    
    .foo {
      @extend %shared;
      font-size: 12px;
    }
    Code:
    /Users/[user]/Code/[project]/front-end/sencha app build testing > error.log
    The logfile is here: error.txt

    The result that was expected:
    • It should've compiled like usual.
    The result that occurs instead:
    • Compilation fails, of course.
    • I think Sencha Cmd actually used an internal jRuby/Compass, or the default Mac OS X version of Ruby, rather than the system Ruby that is set via rbenv (should be easily available via "/usr/bin/env ruby").
    Last edited by robert_k; 27 Mar 2013 at 4:58 AM. Reason: Fixed title

  2. #2
    Sencha - Senior Forum Manager mitchellsimoens's Avatar
    Join Date
    Mar 2007
    Location
    Gainesville, FL
    Posts
    35,704
    Vote Rating
    751
    mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute mitchellsimoens has a reputation beyond repute

      0  

    Default


    Thanks for the report! I have opened a bug in our bug tracker.

  3. #3
    Sencha Premium Member
    Join Date
    Apr 2008
    Posts
    215
    Vote Rating
    18
    themightychris will become famous soon enough themightychris will become famous soon enough

      0  

    Default


    I've run into this problem as well, it appears that CMD 3.1 ships with a really old version of SASS (3.1.7) while 3.0 used the newer version installed on my system. I'm looking for a clean way to override the compass binary path via sencha.cfg somewhere, is there a setting?
    Chief Architect @ Jarv.us Innovations
    Co-captain @ Code for Philly
    Co-founder @ Devnuts - Philadelphia Hackerspace

  4. #4
    Sencha Premium Member robert_k's Avatar
    Join Date
    Jun 2012
    Posts
    35
    Vote Rating
    1
    robert_k is on a distinguished road

      0  

    Default


    The only way I was able to work around this was to revert to Sencha CMD 3.0.2. I wasn't able to come up with a way to keep the newest version of Sencha CMD.

  5. #5
    Sencha Premium Member
    Join Date
    Apr 2008
    Posts
    215
    Vote Rating
    18
    themightychris will become famous soon enough themightychris will become famous soon enough

      0  

    Default


    I've got the newest CMD using my system gems with this ugly hack:

    1) Rename /usr/local/bin/Sencha/Cmd/3.1.0.256/extensions/sencha-compass/gems to gems.bak
    2) Create empty directory in its place
    3) Fill with symlinks:
    Code:
    lrwxrwxrwx 1 root root 14 Apr  8 14:26 bin -> /usr/local/bin
    lrwxrwxrwx 1 root root 36 Apr  8 14:25 cache -> /usr/local/lib64/ruby/gems/1.8/cache
    lrwxrwxrwx 1 root root 35 Apr  8 14:25 gems -> /usr/local/lib64/ruby/gems/1.8/gems
    lrwxrwxrwx 1 root root 45 Apr  8 14:25 specifications -> /usr/local/lib64/ruby/gems/1.8/specifications
    Chief Architect @ Jarv.us Innovations
    Co-captain @ Code for Philly
    Co-founder @ Devnuts - Philadelphia Hackerspace

  6. #6
    Sencha Premium Member
    Join Date
    Apr 2008
    Posts
    215
    Vote Rating
    18
    themightychris will become famous soon enough themightychris will become famous soon enough

      0  

    Default


    @mitchellsimoens - can we just get a version bump for the sass gem in the next CMD build to 3.2.7?
    Chief Architect @ Jarv.us Innovations
    Co-captain @ Code for Philly
    Co-founder @ Devnuts - Philadelphia Hackerspace

  7. #7
    Sencha Premium Member robert_k's Avatar
    Join Date
    Jun 2012
    Posts
    35
    Vote Rating
    1
    robert_k is on a distinguished road

      0  

    Default


    Where are we on resolution of this issue? I'm willing to help test a beta version of Sencha CMD to try and resolve the issue.

  8. #8
    Ext JS Premium Member
    Join Date
    Jun 2009
    Posts
    7
    Vote Rating
    1
    r.binna is on a distinguished road

      1  

    Default Problem still applies to CMD 4.0.0.203

    Problem still applies to CMD 4.0.0.203


    The Problem still applies to sencha CMD 4.0.0.203. This is rather annoying as I am currently migrating the project structure from a custom build to the sencha suggested workspace structure. Due to the old SASS version (sencha CMD 4.0.0.203 is still bundled with sass-3.1.7) the SASS-build containing placeholder selectors now breaks eventhough I am using your latest tool set.

film izle

hd film izle

film sitesi

takipci kazanma sitesi

takipci kazanma sitesi

güzel olan herşey

takipci alma sitesi

komik eğlenceli videolar