1. #1
    Sencha Premium Member
    Join Date
    Apr 2009
    Posts
    193
    Vote Rating
    8
    jhoweaa is on a distinguished road

      0  

    Default Sench CMD Build Problem with 4.2.0.489

    Sench CMD Build Problem with 4.2.0.489


    I've downloaded the latest (or what was the latest) Ext JS 4.2 build (489) along with the latest Sencha CMD (3.1.0.256). I'm playing around with building a multi-page application and workspaces, so the first thing I did was generate the workspace and then generated the app. When I tried to generate the app, I received the following message:

    com.sencha.exceptions.ExNotFound: Required packages not found

    When I switched to the application directory and tried to do a sencha app build, I received the following:

    [WRN] Package ext-theme-classic has unrecognized type LIB
    [WRN] Package ext-theme-classic has unrecognized type LIB
    [INF] Including LIB package ext-theme-classic for build
    [ERR] Theme ext-theme-classic not found
    [ERR] Required packages not found

    Is there a compatibility problem with CMD 3.1.0.256 and Ext JS 4.2.0.489? Is there an easy way to patch things up so the build will succeed?

    Thanks

    Jim

  2. #2
    Sencha Premium Member
    Join Date
    Apr 2009
    Posts
    193
    Vote Rating
    8
    jhoweaa is on a distinguished road

      0  

    Default


    A bit more information, I was trying to follow the instructions in the new 4.2 Theming guide. I generated the workspace and when I generated the first 'app' I received a bunch of 'INF' messages followed by these:

    [WRN] Package ext-theme-classic has unrecognized type LIB
    [WRN] Package ext-theme-classic has unrecognized type LIB
    [INF] Including LIB package ext-theme-classic for build
    [ERR] Theme ext-theme-classic not found
    [ERR]
    [ERR] BUILD FAILED
    [ERR] com.sencha.exceptions.ExNotFound: Required packages not found
    [ERR]
    [ERR] Total time: 1 second
    [ERR] com.sencha.exceptions.ExNotFound: Required packages not found

    Just an additional note, I'm running Sencha CMD under cygwin on my Windows box. I've been using an earlier version of Sencha CMD for a 4.1 application in this environment without any problems.

    Jim

  3. #3
    Sencha Premium Member
    Join Date
    Jan 2013
    Posts
    42
    Vote Rating
    4
    Dev@QLP is on a distinguished road

      0  

    Default


    Quote Originally Posted by jhoweaa View Post
    Is there a compatibility problem with CMD 3.1.0.256 and Ext JS 4.2.0.489? Is there an easy way to patch things up so the build will succeed?
    I think I remember having some problems but when I switched to the final version of 4.2 (4.2.0.669) everything started to work fine. I believe 4.2.0.489 is the RC (Release Candidate) version anyways.

    Thanks,
    Tim

Thread Participants: 1

Tags for this Thread