Looks like we can't reproduce the issue or there's a problem in the test case provided.
  1. #1
    Sencha User
    Join Date
    Jul 2009
    Posts
    61
    Vote Rating
    2
    ibnesayeed is on a distinguished road

      0  

    Default Neptune Theme Difference In Development And Production

    Neptune Theme Difference In Development And Production


    My development environment:

    OS: Linux Ubuntu 12.4
    ExtJS: 4.2.0.663
    Sencha Cmd: 3.1.0.256
    Ruby: 1.9.3p0
    Browsers: Google Chrome 26.0.1410.43, Firefox 20.0

    Reproduction Steps:

    Create a fresh application using Sencha Cmd
    Change theme to "ext-theme-neptune" in sencha.cfg
    Build the app using Sencha Cmd

    Open the application's development root location and production root location (build/MyApp/production/) in separate browser tabs and see the differences in borders/marfins/paddings/frames? of the two. Please find the two attachments showing the difference.
    Attached Images

  2. #2
    Sencha - Support Team slemmon's Avatar
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    4,800
    Vote Rating
    167
    slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold

      0  

    Default


    Thank you very much for the bug report!
    Looks like this one's in-flight currently.

  3. #3
    Sencha User
    Join Date
    Jul 2009
    Posts
    61
    Vote Rating
    2
    ibnesayeed is on a distinguished road

      0  

    Default


    I believe that this report is not a duplicate of the other linked report. It might have similar nature though. The other report is talking about an issue in the development version while this one is talking about the issue in the production build.

    Today I have experienced another issue in the production build. I have configured a paging toolbar with "ui" property set to "footer". In the development app it shows darker buttons and icons (first/prev/next/last/refresh) while in the production build it shows the icons as it shows if the "ui" property was set to default. As an added note, my application is a RTL application and I did not try to see if it exists in LTR mode as well or not.

  4. #4
    Sencha - Support Team slemmon's Avatar
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    4,800
    Vote Rating
    167
    slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold

      0  

    Default


    Thanks for the report! I have opened a bug in our bug tracker.

  5. #5
    Sencha Premium Member
    Join Date
    Mar 2012
    Posts
    71
    Vote Rating
    5
    Lukappa is on a distinguished road

      0  

    Default Different themes extending neptune

    Different themes extending neptune


    Hello,
    I have the same problem trying to build my custom theme (extending neptune)...
    I'm following the theming guide with a new app and clean code (no changes on js/sass )
    http://docs.sencha.com/extjs/4.2.0/#!/guide/theming

    Any news about this bug? Do you think it will be fixed for the end of this month?

    Thank you

  6. #6
    Sencha User mysticav's Avatar
    Join Date
    Mar 2007
    Location
    Mexico
    Posts
    474
    Vote Rating
    5
    mysticav is on a distinguished road

      0  

    Default


    I can't believe it wasn't fixed in 4.2.1.883
    Using Ext with cachefly
    Working on LAMPExt

  7. #7
    Sencha User
    Join Date
    Jul 2009
    Posts
    61
    Vote Rating
    2
    ibnesayeed is on a distinguished road

      0  

    Default


    Quote Originally Posted by mysticav View Post
    I can't believe it wasn't fixed in 4.2.1.883
    Was there any other release after beta-1 yet, sir?

  8. #8
    Sencha User mysticav's Avatar
    Join Date
    Mar 2007
    Location
    Mexico
    Posts
    474
    Vote Rating
    5
    mysticav is on a distinguished road

      0  

    Default


    Isn't the bug reported between 4.2.1.744 and 4.2.1.883 ?

    Anyways, I should shout my mouth and wait. I'm just a little desperate to get this bug done, because does not allow me to build (and release) an application.

    Nothing personal, sir.
    Using Ext with cachefly
    Working on LAMPExt

  9. #9
    Sencha User
    Join Date
    Jul 2009
    Posts
    61
    Vote Rating
    2
    ibnesayeed is on a distinguished road

      0  

    Default


    Quote Originally Posted by mysticav View Post
    Isn't the bug reported between 4.2.1.744 and 4.2.1.883 ?
    I think I have reported it even before beta 1 (4.2.1.744) was released and we did not see it fixed in that beta release. If 4.2.1.883 is beta 2 then I am not aware of this second beta release so I can't comment about it. Could you please point me to the thread where 4.2.1.883 was announced or from where I can download it.
    Anyways, I should shout my mouth and wait for the bug reporter to comment. I'm just a little desperate to get this bug done, because does not allow me to build (and release) an application.
    We both are in the same ship then. In fact there are few more bugs that I have reported that are preventing me from releasing an odd looking application.
    Nothing personal, sir.
    I have asked that question because I was really not aware of 4.2.1.883 release. Please don't take it personal, sir.

  10. #10
    Sencha Premium Member
    Join Date
    Mar 2012
    Posts
    71
    Vote Rating
    5
    Lukappa is on a distinguished road

      0  

    Default


    +1 @mysticav @ibnesayeed

    Please fix it ASAP

    Thank you