1. #1
    Sencha Premium Member
    Join Date
    Mar 2011
    Location
    Betelgeuse VII
    Posts
    88
    Vote Rating
    3
    fordprefect is on a distinguished road

      0  

    Default Upgrade 4.1.1 -> 4.2.1 beta questions

    Upgrade 4.1.1 -> 4.2.1 beta questions


    Hi,

    I'm attempting to upgrade my existing application to use the new beta and Sencha Cmd conventions and have a few questions:

    1. I see in the guide it says to use cmd to generate controllers, models, views, etc. When I use Sencha Cmd to do so I see references created to these new files in the codegen.json file. I'm wondering if I have to use this new method to add my existing controllers, models, views, etc. so that the build will work properly or if I can add them to the project manually as before and have the build process still work.

    2. I see there's a new overrides folder: should I move my existing overrides here?

    3. What version of Ruby do I need to use? I'm running 2.0 and getting sass "NoMethodError" errors attempting to build a newly generated empty app.

    Thanks.

  2. #2
    Sencha Premium Member
    Join Date
    Mar 2011
    Location
    Betelgeuse VII
    Posts
    88
    Vote Rating
    3
    fordprefect is on a distinguished road

      1  

    Default


    I've been able to answer my own questions, I'll put the answers here in case anyone else has similar questions:

    1. No, you can add files manually.

    2. Yes, you can move your overrides if you'd like.

    3. Ruby 2.0 doesn't appear to work, 1.9.3-p392 seems to work fine.