How to take something that you have working on the command lone and translate it into an ant target?

Here I am working with the example from the docs.

This works from the cmd line:

Code:
cd /home/killme
sencha compile -classpath=/home/steward/public_html/ext/src \
    exclude -namespace Ext.chart and \
    concat my-ext-all-nocharts-debug-w-comments.js and \
    -debug=true \
    concat -strip my-ext-all-nocharts-debug.js and \
    -debug=false \
    concat -yui my-ext-all-nocharts.js
So I create an ant script to do the same:

Code:
<?xml version="1.0" encoding="utf-8"?>
<project name="test" default="nocharts">

    <taskdef resource="com/sencha/ant/antlib.xml"
         classpath="${cmd.dir}/sencha.jar"/>
    <x-sencha-init prefix=""/>

    <target name="nocharts"  >
        <x-sencha-command>
        compile
            -classpath=/home/steward/public_html/ext/src
            exclude
            -namespace Ext.chart
            and
            concat
            ant-all-nocharts-debug-w-comments.js
            and
            -debug=true
            concat
            -strip ant-all-nocharts-debug.js
            and
            -debug=false
            concat 
                -yui 
                ant-all-nocharts.js
        </x-sencha-command>
    </target>

</project>

As expected, I had to insert a lot of line breaks.

It runs with no errors.

Code:
hankBook:killme steward$ sencha ant -f nocharts.xml
Sencha Cmd v3.1.0.256
[INF] Initializing Sencha Cmd ant environment
[INF] Adding antlib taskdef for com/sencha/command/compass/ant/antlib.xml
[INF] 
[INF] nocharts:
[INF] Loading classpath entry /home/steward/public_html/ext-4.2.0.663/src

But it does not produce output either.
What is missing please?


Point of confusion: the docs at http://docs.sencha.com/extjs/4.2.0/#...mmand_compiler say

The one required parameter is -out, which indicates the name of the output file.

Here, neither the command line nor the ant task include "-out".