1. #1
    Sencha User
    Join Date
    Feb 2012
    Location
    Toronto, Canada
    Posts
    25
    Vote Rating
    1
    burrellramone is on a distinguished road

      0  

    Default Unanswered: Native Android Packaging Issue

    Unanswered: Native Android Packaging Issue


    Hi everyone. I have been experiencing an issue for quite sometime now. I am at the point of packaging my app for Android 4.0.3 (API Level 15). The issue that I am having is that after running the command sencha app package run <config.json> the application does not start. Instead, It only shows a blank dark grey background with the app icon to the top left of the window. When I inspect the logcat messages, the only error I notice is

    No content provider found for permission revoke: file:///data/local/tmp/<app>.apk.

    I currently using version v3.1.1.274 of Sencha Command and my sdk tools are fully up to date. Also, i made sure that I created a keystore for the application so I am almost sure that this is not what is causing the issue.

    What might I be doing wrong?

  2. #2
    Sencha Premium Member richardvd's Avatar
    Join Date
    Jun 2011
    Location
    NL
    Posts
    49
    Vote Rating
    14
    Answers
    4
    richardvd will become famous soon enough

      0  

    Default


    I use 'sencha app build native' and install/run the resulting .apk on my phone (and use the CatLog app to view the console output), that works for me.


    I'd like to try the emulator, but 'sencha app package run packager.json' doesn't work for me, how to you get the emulator to show up?
    Richard