1. #1
    Sencha User
    Join Date
    May 2013
    Posts
    7
    Vote Rating
    0
    jregan is on a distinguished road

      0  

    Default Packager outputPath ignored

    Packager outputPath ignored


    As far as I can tell, it seems like the outputPath parameter in the packager.json is ignored when building in SA.

    I've verified that my path is valid; I tried an invalid path too and it built just fine.

    I see this in the build-impl.xml that's referred to by the build.xml ant file so I'm guessing that it just defaults to the workspace settings.

    <!--
    initialize the app.build.dir property to the original default
    this one will be overridden by the new default located in .sencha/app/sencha.cfg
    if present
    -->
    <property name="app.build.dir" location="${workspace.build.dir}"/>


  2. #2
    Sencha - Architect Dev Team
    Join Date
    Jan 2009
    Location
    Frederick, Maryland
    Posts
    922
    Vote Rating
    32
    jminnick has a spectacular aura about jminnick has a spectacular aura about

      1  

    Default


    Take a look at this and see if it helps you out at all:

    http://www.sencha.com/forum/showthre...-specification
    Jason Minnick
    Sencha Architect Development Team

  3. #3
    Sencha User
    Join Date
    May 2013
    Posts
    7
    Vote Rating
    0
    jregan is on a distinguished road

      0  

    Default


    Thanks for your response to this and my other similar question. I don't think this explains why the output directory parameter is being used but it does explain the difference between the app and package options and maybe some of the direction of Sencha in this regard.

Thread Participants: 1

Tags for this Thread