1. #1
    Sencha User
    Join Date
    Mar 2013
    Posts
    4
    Vote Rating
    0
    vakhsakhalyan is on a distinguished road

      0  

    Default Ext js 4.2.1 editable radiogroup

    Ext js 4.2.1 editable radiogroup


    When I update extjs 4.2 to 4.2.1 I have some problems with editable radiogroup. So, here is my code:
    Code:
     
    
    this.dashboardRadioGroup = Ext.create('Ext.form.RadioGroup', {         items: [{            boxLabel: bundle['dashboard.reorderAutoTransitionOn'],            name: "autoswitchEnabled",            inputValue: "On"         },{            boxLabel: bundle['dashboard.reorderAutoTransitionOff'],            name: "autoswitchEnabled",            inputValue: "Off"         }] });
    
    and then I use it in grid panel column :

    Code:
    ........
    {
                text: bundle['dashboard.reorderAutoTransition'],            dataIndex: 'autoswitchEnabled',            scope: this,            width: 100,            sortable: false,            editor: {                xtype: this.dashboardRadioGroup,////problem                allowBlank: false            } }.....
    .
    .And :
    Code:
    this.tabRowEditing = Ext.create('Ext.grid.plugin.RowEditing', {         clicksToEdit: 1 });
    
    Now when I upgrade extjs to 4.2.1 I have problem. So I get this error Msg:Uncaught TypeError: Cannot call method 'isVisible' of undefined, and this Msg:Uncaught TypeError: Cannot call method 'getHeight' of undefined and when I click to edit row it isn't activate.

  2. #2
    Sencha User
    Join Date
    Jun 2009
    Posts
    17
    Vote Rating
    1
    olof is on a distinguished road

      0  

    Default


    Hi, I am afraid we are seeing the same issue with grids after upgrading from ext-4.1.1a to ext-4.2.1.883.

    Uncaught TypeError: Cannot call method 'isVisible' of undefined
    Uncaught TypeError: Cannot call method 'parent' of undefined

    Does anyone have any clues as to what we should be looking for to resolve this type of issues after an upgrade from ext-4.1.1a to ext-4.2.1.883?

    Kind regards

    Olof

  3. #3
    Sencha - Support Team slemmon's Avatar
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    5,357
    Vote Rating
    200
    slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of

      0  

    Default


    It was working ok for you in 4.2.0 you say?

    Do you have a test case that works in 4.2.0?
    Are you a Sencha products veteran who has wondered what it might be like to work at Sencha? If so, please reach out to our recruiting manager: sheryl@sencha.com

  4. #4
    Sencha User
    Join Date
    Mar 2013
    Posts
    4
    Vote Rating
    0
    vakhsakhalyan is on a distinguished road

      0  

    Default


    Quote Originally Posted by slemmon View Post
    It was working ok for you in 4.2.0 you say?

    Do you have a test case that works in 4.2.0?
    Yes , it was working in 4.2.0 well. but in 4.2.1 not working. I test it in 4.2.0

  5. #5
    Sencha - Support Team slemmon's Avatar
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    5,357
    Vote Rating
    200
    slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of slemmon has much to be proud of

      0  

    Default


    I was seeing the same results in 4.2.0 and 4.2.1, but I suspect I didn't set up the test case correctly. Can you provide an inclusive test case that works for you in 4.2.0?
    Are you a Sencha products veteran who has wondered what it might be like to work at Sencha? If so, please reach out to our recruiting manager: sheryl@sencha.com

  6. #6
    Sencha User
    Join Date
    Mar 2013
    Posts
    4
    Vote Rating
    0
    vakhsakhalyan is on a distinguished road

      0  

    Default


    Quote Originally Posted by slemmon View Post
    I was seeing the same results in 4.2.0 and 4.2.1, but I suspect I didn't set up the test case correctly. Can you provide an inclusive test case that works for you in 4.2.0?
    I was testing it locally and was seeing that it working in extjs4.2.
    I was wrote this part of code using xtype : 'radiogroup' and then I used renderer.