1. #1
    Sencha User
    Join Date
    May 2013
    Posts
    2
    Vote Rating
    0
    hitfishking is on a distinguished road

      0  

    Default Unanswered: Why 'disableCaching: false' not work?

    Unanswered: Why 'disableCaching: false' not work?


    There are several threads in this forum discussing how to turn off the '_dc=' param from url.

    Following those discussions, I config my project with the code below:

    Following is my code:
    PHP Code:
    Ext.Loader.setConfig({
       
    disableCachingfalse,
       
    disableCachingParam'_dc1',
       
    enabledtrue,
       ... 

    When I preview, the url remains unchanged, the '_dc' param is still there. It seems the above code didn't work at all.


    What I missed? Any suggestion would be appreciated!






  2. #2
    Sencha - Support Team slemmon's Avatar
    Join Date
    Mar 2009
    Location
    Boise, ID
    Posts
    4,993
    Answers
    380
    Vote Rating
    183
    slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold slemmon is a splendid one to behold

      0  

    Default


    The following worked for me:
    Code:
    Ext.Loader.setConfig({
        enabled        : true,
        disableCaching : false
    });
    When I set disableCaching to true I see the URL requesting classes generated like:
    http://localhost/ext-4.2.1.883/src/t...=1374702931666

    With disableCaching set to false I see:
    http://localhost/ext-4.2.1.883/src/tip/ToolTip.js
    Are you a Sencha products veteran who has wondered what it might be like to work at Sencha? If so, please reach out to our recruiting manager: sheryl@sencha.com

    C
    heck out all of the 2013 SenchaCon presentations here:
    http://www.sencha.com/blog/senchacon...now-available/

Thread Participants: 1

Tags for this Thread