1. #1
    Sencha User
    Join Date
    Aug 2011
    Posts
    22
    Vote Rating
    1
    vipul30 is on a distinguished road

      0  

    Default Unanswered: The application was last modified by an older version of Sencha Cmd...

    Unanswered: The application was last modified by an older version of Sencha Cmd...


    I upgraded an app from a previous version of Sencha. I get this error message when I try to build

    [ERR]
    The application was last modified by an older version of Sencha Cmd (3.0.2.288)
    the current is 4.0.0.193.
    Please run "sencha app upgrade" to update to 4.0.0.193.

    I tried to run the sencha app upgrade <dir path>, but it doesn't seem to work. Maybe I'm using the wrong directory path. Can some please help out? Thank you.

  2. #2
    Sencha Premium Member
    Join Date
    Jun 2012
    Posts
    123
    Answers
    6
    Vote Rating
    6
    benjamineberle is on a distinguished road

      0  

    Default


    Same thing here, my error msg is saying:

    The application was last modified by an older version of Sencha Cmd (0.0.0.0) the current is 4.0.0.203.

  3. #3
    Sencha User
    Join Date
    Aug 2010
    Posts
    34
    Vote Rating
    0
    aratcliffe is on a distinguished road

      0  

    Default


    I have exactly the same problem:
    "
    The application was last modified by an older version of Sencha Cmd (0.0.0.0) the current is 4.0.0.203."

  4. #4
    Sencha Premium Member
    Join Date
    Jun 2012
    Posts
    123
    Answers
    6
    Vote Rating
    6
    benjamineberle is on a distinguished road

      0  

    Default


    In my case it was a misleading error message. Scan the log output thoroughly and you should be able to find the actual problem. Even faulty javascript can lead to the above error message.

    http://www.sencha.com/forum/showthre...-%280.0.0.0%29

  5. #5
    Sencha User
    Join Date
    Aug 2010
    Posts
    34
    Vote Rating
    0
    aratcliffe is on a distinguished road

      0  

    Default


    @benjamineberle I initially tried upgrading the cmd version and the framework version at the same time but am now attempting to upgrade cmd only with the command
    Code:
    sencha app upgrade --noframework
    . The error log shows a merge conflict with app.'s (shown below). Do you think it would work to resolve the app.js conflict and run
    Code:
    sencha app build
    as the problem seems to be with building the app rather than with cmd being upgraded?

    PHP Code:
    <<<<<<< Generated=======// DO NOT DELETE - this directive is required for Sencha Cmd packages to work.//@require @packageOverrides
    //<debug>Ext.Loader.setPath({    'Ext': 'touch/src',    'Ext.ux': 'ux'});//</debug>
    >>>>>>> Custom 

  6. #6
    Sencha Premium Member
    Join Date
    Jun 2012
    Posts
    123
    Answers
    6
    Vote Rating
    6
    benjamineberle is on a distinguished road

      0  

    Default


    I don't know about this one, but it seems odd that you have custom stuff in app.js
    You can have all your own code in app/Application.js
    Cmd merges your app.js, so maybe try to use a fresh app.js and change Application.js instead.
    Or just start with a fresh template.

  7. #7
    Sencha User
    Join Date
    Aug 2010
    Posts
    34
    Vote Rating
    0
    aratcliffe is on a distinguished road

      0  

    Default


    My app is a sencha touch app where there is no Application.js, app.js is the entry point to the application. I mostly have it working now. The steps I followed were:
    1. Upgrade cmd only: sencha app upgrade --noframework
    2. Manually resolve the merge conflict in app.js
    3. Update the application metadata: sencha app refresh
    4. Upgrade the framework version: sencha app upgrade <path-to-framework-version>
    The last problem I have is with running sencha app build, it appears to be using the wrong path to the build directory.

  8. #8
    Sencha - Architect Dev Team Phil.Strong's Avatar
    Join Date
    Mar 2007
    Location
    Olney, MD
    Posts
    1,879
    Answers
    12
    Vote Rating
    62
    Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice

      0  

    Default


    We came out with a ton of fixes for Cmd related stuff on Friday. Please try using it again and report any issues that arise.

    We do have a known issue regarding app.json with respect to Architect including resources (js,css) multiple times. Expect a patch next week.
    Phil Strong
    @philstrong
    #SenchaArchitect
    Sencha Architect Development Team

Turkiyenin en sevilen filmlerinin yer aldigi xnxx internet sitemiz olan ve porn sex tarzi bir site olan mobil porno izle sitemiz gercekten dillere destan bir durumda herkesin sevdigi bir site olarak tarihe gececege benziyor. Sitenin en belirgin ozelliklerinden birisi de Turkiyede gercekten kaliteli ve muntazam, duzenli porno izle siteleri olmamasidir. Bu yuzden iste. Ayrica en net goruntu kalitesine sahip adresinde yayinlanmaktadir. Mesela diğer sitelerimizden bahsedecek olursak, en iyi hd porno video arşivine sahip bir siteyiz. "The Best anal porn videos and slut anus, big asses movies set..." hd porno faketaxi