1. #1
    Sencha User
    Join Date
    Jun 2013
    Posts
    59
    Answers
    1
    Vote Rating
    3
    good_c_ryan_19 is on a distinguished road

      0  

    Default Unanswered: Ext.device.Notification callback not working in iOS Native build

    Unanswered: Ext.device.Notification callback not working in iOS Native build


    Hi i created native iOS app build in sencha CMD 4.0 and Touch 2.3 . The app was successfully installed but when i tried to click on my button with Ext.Device.Notification function it doesn't go to callback function.

    Below is my code:

    Code:
      onLogoutTap: function () {
    
    
            Ext.device.Notification.show({
                title: 'Verification',
                message: 'Is your email address: test@sencha.com',
                buttons: ['OK','CANCEL'],
                callback: function (button) {
            
                    if (button === "ok") {
                        console.log('Verified');
                    } else {
                        console.log('Nope');
                    }
                }
            });
        }

    I also tried to add alert code inside call back but it doesn't go there.

    Code:
     Ext.Msg.alert('Title', button, Ext.emptyFn);
    Anyone experience this issue? Any help is appreciated.

    Thanks in advance.

  2. #2
    Sencha - Support Team
    Join Date
    Oct 2011
    Posts
    3,936
    Answers
    328
    Vote Rating
    130
    fmoseley is a name known to all fmoseley is a name known to all fmoseley is a name known to all fmoseley is a name known to all fmoseley is a name known to all fmoseley is a name known to all

      0  

    Default


    I can't repro on iOS 7.0.2
    Get more personalized support via a support subscription.

    Want to learn Sencha Touch 2? Check out
    Sencha training
    Sencha Touch in Action

    Need more help with your app? Hire Sencha Services services@sencha.com

    When posting code, please use BBCode's CODE tags.

    Need to include a test case use:
    The official Sencha Fiddle

  3. #3
    Sencha User
    Join Date
    Jun 2013
    Posts
    59
    Answers
    1
    Vote Rating
    3
    good_c_ryan_19 is on a distinguished road

      0  

    Default


    Currently i am using iOS 5 fmosely. I dont have any issue using sencha 2.2.1 and cmd 3. But i'm now digging on the latest version.

    Thanks

Thread Participants: 1

Tags for this Thread