Hybrid View

  1. #1
    Sencha User
    Join Date
    Apr 2013
    Posts
    31
    Vote Rating
    1
    bsougias is on a distinguished road

      0  

    Default Mixed-Mode x-compile and microload markup is currently unsupported

    Mixed-Mode x-compile and microload markup is currently unsupported


    I pressed the "Upgrade CMD" button and got lots of errors, like the following:

    [ERR] com.sencha.exceptions.ExBuild: Mixed-Mode x-compile and microload markup is currently unsupported
    [ERR] at com.s
    [ERR] encha.command.environment.BuildEnvironment.execute(BuildEnvironment.java:245)

  2. #2
    Sencha - Architect Dev Team Phil.Strong's Avatar
    Join Date
    Mar 2007
    Location
    Baltimore, MD
    Posts
    1,851
    Vote Rating
    58
    Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice

      0  

    Default


    Tell me more...

    What did you have in the form fields associated w/ Upgrade?

    Soon we'll have the about screen tell you what versions of Cmd, framework you're working with so that will be helpful
    Phil Strong
    @philstrong
    #SenchaArchitect
    Sencha Architect Development Team

  3. #3
    Sencha User
    Join Date
    Apr 2013
    Posts
    31
    Vote Rating
    1
    bsougias is on a distinguished road

      0  

    Default


    Framework (tab)
    -----------------------

    Ext JS 4.2.x - Documentation URL:
    http://docs.sencha.com/ext-js/4-2/

    Custom framework path:
    <empty>

    Change License
    GPL: <selected> Commercial: <not selected>


    That is all there is in this tab. I click on "Upgrade CMD" and I get the above errors.

  4. #4
    Touch Premium Member svenna's Avatar
    Join Date
    Jun 2007
    Location
    Oslo,Norway
    Posts
    520
    Vote Rating
    22
    svenna has a spectacular aura about svenna has a spectacular aura about

      0  

    Default


    I get the same message, from cmd. When I run "sencha app build" after upgrading cmd from 3 to 4, and also upgrading the framework from 4.2.1 to 4.2.2.

    The upgrade failed, and I''m in the process of doing a manual upgrade (apparently not done yet ).

    Snippet from the logfile:

    [INF] -init:
    [INF]
    [INF] -init-compiler:
    [INF]
    [INF] -detect-app-build-properties:
    [INF] Loading app json manifest...
    [ERR]
    [ERR] BUILD FAILED
    [ERR] com.sencha.exceptions.ExBuild: Mixed-Mode x-compile and microload markup is currently unsupported
    [ERR]
    [ERR] Total time: 3 seconds
    [ERR] The following error occurred while executing this line:
    R:\mystrippedprojectpath\.sencha\app\build-impl.xml:359: The following error occurred while executing this line:
    R:\mystrippedprojectpath\.sencha\app\js-impl.xml:11: com.sencha.exceptions.ExBuild: Mixed-Mode x-compile and microload markup is currently unsupported.


    I found that if I remove the js and css parts from app.json (the "genererated by SA do not edit parts"), then cmd works happily, and builds my project
    Sven Tore Iversen

  5. #5
    Touch Premium Member svenna's Avatar
    Join Date
    Jun 2007
    Location
    Oslo,Norway
    Posts
    520
    Vote Rating
    22
    svenna has a spectacular aura about svenna has a spectacular aura about

      0  

    Default


    I've been testing this a tittle back and worth and currently I've found that I have to open app.json before every build and remove js and css resources that SA have added, before building with cmd.

    SA needs the resources defined to be able to use my custom css and locale js file in development/preview mode, but I have to remove them again to build.
    Sven Tore Iversen

  6. #6
    Sencha - Architect Dev Team Phil.Strong's Avatar
    Join Date
    Mar 2007
    Location
    Baltimore, MD
    Posts
    1,851
    Vote Rating
    58
    Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice

      0  

    Default


    Oh man we have a bug I'm working on right now that malforms the app.json. Can you send me a copy of your app.json?
    Phil Strong
    @philstrong
    #SenchaArchitect
    Sencha Architect Development Team

  7. #7
    Sencha - Architect Dev Team Phil.Strong's Avatar
    Join Date
    Mar 2007
    Location
    Baltimore, MD
    Posts
    1,851
    Vote Rating
    58
    Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice

      0  

    Default


    if you need to add things to app.json, you need to move everything from the x-compile section of index.html to app.json as well, then get rid of x-compile from index.html.

    I believe you can use 1 method or the other.
    Phil Strong
    @philstrong
    #SenchaArchitect
    Sencha Architect Development Team

  8. #8
    Touch Premium Member
    Join Date
    Sep 2010
    Location
    UK
    Posts
    54
    Vote Rating
    1
    Joe Kuan is on a distinguished road

      1  

    Default Same error, please help

    Same error, please help


    I got the same error with simple app.json, app.js and index.html
    Sencha Cmd v4.0.1.45

    app.json
    PHP Code:
    {
        
    "name""Sencha_Cmd_Test",
        
    "requires": [
        ]

    app.js
    PHP Code:
    Ext.application({
        
    name'Sencha_Cmd_Test',


        
    extend'Sencha_Cmd_Test.Application',
        
        
    autoCreateViewporttrue
    }); 
    index.html
    HTML Code:
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html>
      <head>
        <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
        <title>Standalone example for ExtJs 4</title>
        <script type="text/javascript" src="ext/bootstrap.js"></script>
        <script type='text/javascript' src="./app.js"></script>
      </head>
      <body id="docbody">
    </body></html>
    I have no experience in using Sencha Cmd and I am a bit clueless with this error message.

  9. #9
    Sencha User
    Join Date
    Feb 2011
    Posts
    2
    Vote Rating
    0
    amsoares is on a distinguished road

      0  

    Default


    I'm facing the same problem

    Code:
    -build-output-markup-page:[INF] Building output markup to /path/to/project/index.html[ERR] [ERR] BUILD FAILED[ERR] java.lang.NullPointerException[ERR] [ERR] Total time: 16 seconds[ERR] The following error occurred while executing this line:/path/to/project/.sencha/app/build-impl.xml:385: The following error occurred while executing this line:/path/to/project/.sencha/app/page-impl.xml:122: The following error occurred while executing this line:/path/to/project/.sencha/app/page-impl.xml:108: java.lang.NullPointerException
    Any help?

  10. #10
    Sencha - Architect Dev Team Phil.Strong's Avatar
    Join Date
    Mar 2007
    Location
    Baltimore, MD
    Posts
    1,851
    Vote Rating
    58
    Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice Phil.Strong is just really nice

      0  

    Default


    Again if you want to put things in your app.json then you need to go all in. This means you cannot have any x-compile, x-bootstrap directives in your index.html file.

    You can either use index.html to include files or app.json but not both.
    Phil Strong
    @philstrong
    #SenchaArchitect
    Sencha Architect Development Team