Threaded View

  1. #1
    Sencha User
    Join Date
    Jun 2013
    Posts
    3
    Vote Rating
    0
    ndjb20 is on a distinguished road

      0  

    Default Class extend upgrade from 1.1.1 to 2.3.0

    Class extend upgrade from 1.1.1 to 2.3.0


    Hi,

    I am updating my code from 1.1.1 to 2.3.0, I've made all the changes required by the upgrade guide (and the comments). When I create a base class from a panel and then extend the base class I keep getting the loader error:
    Uncaught Error: [Ext.Loader] Failed loading 'Base/Panel.js', please verify that the file exists

    An example of the code I use is:
    Ext.define('Base.Panel', {
    extend: 'Ext.Panel',
    (...)
    });

    Ext.define('Another.Panel', {
    extend: 'Base.Panel',
    (...)
    });

    Am I missing something, has someone else faced similar issues?

    -- Edit --

    Noticed this was happening because I had all the classes in a single file. I just want to upgrade easily. So my new question would be: Is there a way of leaving all the classes in a single file?

    Last edited by ndjb20; 1 Nov 2013 at 8:36 AM. Reason: Change of focus

Thread Participants: 1

Tags for this Thread

Turkiyenin en sevilen filmlerinin yer aldigi xnxx internet sitemiz olan ve porn sex tarzi bir site olan mobil porno izle sitemiz gercekten dillere destan bir durumda herkesin sevdigi bir site olarak tarihe gececege benziyor. Sitenin en belirgin ozelliklerinden birisi de Turkiyede gercekten kaliteli ve muntazam, duzenli porno izle siteleri olmamasidir. Bu yuzden iste. Ayrica en net goruntu kalitesine sahip adresinde yayinlanmaktadir. Mesela diğer sitelerimizden bahsedecek olursak, en iyi hd porno video arşivine sahip bir siteyiz. "The Best anal porn videos and slut anus, big asses movies set..." hd porno faketaxi