1. #1
    Sencha User
    Join Date
    Sep 2013
    Posts
    29
    Vote Rating
    1
    mwilliamsShields is on a distinguished road

      0  

    Default Architect Stuck in Fullscreen Mac OS

    Architect Stuck in Fullscreen Mac OS


    I'm having a problem where Architect is stuck. Architect is not actually in full screen mode, but it thinks it is. Because of this I cannot change the size of the window or move the window around the screen. Even the mac shortcut to toggle fullscreen will not work. I've tried restarting architect, and restarting my Mac but nothing is working.

    I believed this issue was caused when I had architect open in fullscreen mode then I shutdown my Mac without closing architect. A message came up saying that architect prevented the computer from shutting down but then I clicked the dialog telling to computer to shut down anyways. So I'm guessing that when architect was force closed by the OS while in fullscreen mode it caused this issue.

    I'm currently using Architect 3.0.3.1382

  2. #2
    Sencha - Architect Dev Team jjohnston's Avatar
    Join Date
    Sep 2010
    Posts
    567
    Vote Rating
    20
    jjohnston will become famous soon enough jjohnston will become famous soon enough

      1  

    Default


    Yikes, sounds bad! Architect does store its last window state (normal/fullscreen) in its local storage; maybe it's trying to put itself back in that state on launch but not actually triggering the OS to make it truly fullscreen...? I haven't been able to reproduce it though.

    Assuming that local storage setting is the problem, try this:
    • Exit Architect
    • Go to /Users/you/Library/Application Support/Sencha/Sencha Architect 3.0
    • Rename the Local Storage directory to something else, or delete it
    • Start up Architect
    Let me know if that helps.
    Jason Johnston
    @lojjic
    Sencha Architect Development Team

  3. #3
    Sencha User
    Join Date
    Sep 2013
    Posts
    29
    Vote Rating
    1
    mwilliamsShields is on a distinguished road

      0  

    Default


    Awesome! This worked!

    Thanks for responding so quickly!

Thread Participants: 1