I'm trying to write an app utilize the Windows Azure extension in Architect 3.0.4.1386
When I try to to run the app, it throws an exception.

Uncaught Error: The following classes are not declared even if their files have been loaded: 'Ext.device.Push'. Please check the source code of their corresponding files for possible typos: '../../touch/src/azure/override/device/Push.js

I assume it's some kind of version conflict problem, but not exactly sure what to do to make it cooperate.

In the Push.js file references above, the class is declared under a conditional statement where the touch version is less than 2.3. I can make the error go away by changing the less than 2.3 to 2.4, but this doesn't seem to be the intended method.

​Any ideas?