Hi! Everyone I am studying animation course right now so, just now i have decided to download the sencha animator plugin to my firefox browser but my doubt is I am using older version of firefox browser namely the version of firefox version 15 due to some problems i could not update my browser. I have seen in the sencha website that it is indicated the applicable versions to only IE browser as IE10+ So, I request you all to guide me by telling the applicable version which will be suitable sencha animator plugin of version Rich CSS3 animations version.