1. #1
    Ext User
    Join Date
    Apr 2008
    Posts
    18
    Vote Rating
    0
    kcaseye is on a distinguished road

      0  

    Exclamation [FIXED] Error when compiling gxt.jar

    [FIXED] Error when compiling gxt.jar


    I get this error when I compile using the gxt.jar file that I downloaded from this site.

    bad class file: F:\Isaac\AdminClient\gxt-1.0-beta1\gxt.jar(com/extjs/gxt/ui/client/mvc/AppEvent.class)
    class file has wrong version 50.0, should be 49.0
    Please remove or make sure it appears in the correct subdirectory of the classpath.
    import com.extjs.gxt.ui.client.mvc.AppEvent;
    1 error
    OS: Windows XP
    IDE: Netbeans with GWT4NB plugin

    (I have compiled with MyGWT 0.5.2 using Netbeans, so I don't think that's the problem.)

  2. #2
    Ext User
    Join Date
    Apr 2008
    Posts
    9
    Vote Rating
    0
    jayj is on a distinguished road

      0  

    Default


    gxt 1.0 needs JDK 1.5.

  3. #3
    Ext User
    Join Date
    Apr 2008
    Posts
    18
    Vote Rating
    0
    kcaseye is on a distinguished road

      0  

    Default


    I'm using jdk 1.5. That's not the problem.

  4. #4
    Sencha - GXT Dev Team darrellmeyer's Avatar
    Join Date
    May 2007
    Location
    Washington, DC
    Posts
    2,241
    Vote Rating
    2
    darrellmeyer is on a distinguished road

      0  

    Default


    The problem is that gxt.jar contains 1.6 bytecode.

    49.0 = 1.5
    50.0 = 1.6

    I have fixed the build to produce 1.5 bytecode. The changes are in SVN and will go out in the next rev.

    For a workaround, you can use JDK 1.6. Let me know if you still have problems.

  5. #5
    Ext User
    Join Date
    Apr 2008
    Posts
    18
    Vote Rating
    0
    kcaseye is on a distinguished road

      0  

    Default


    When will the next revision come out? And how often do revisions come out in general?

  6. #6
    Ext GWT Premium Member gslender's Avatar
    Join Date
    Mar 2008
    Location
    Brisbane, Australia
    Posts
    1,572
    Vote Rating
    2
    gslender is on a distinguished road

      0  

    Default


    darrell, this kind of bug is where you shouldn't be waiting for the next release ... clearly if Ext GXT needs 1.6 than fair enough, but this is actually stopping people from using 1.0 as, like me, they probably don't want to upgrade their VM as this can cause other incompatiblities - lucky for me I grabbed a snapshot of the SVN a few days ago and can continue working...

  7. #7
    Sencha - GXT Dev Team darrellmeyer's Avatar
    Join Date
    May 2007
    Location
    Washington, DC
    Posts
    2,241
    Vote Rating
    2
    darrellmeyer is on a distinguished road

      0  

    Default


    There will be a rapid release cycle while we are in beta. Beta2 will be available soon.

  8. #8
    Ext User
    Join Date
    Apr 2008
    Posts
    26
    Vote Rating
    0
    rreckel is on a distinguished road

      0  

    Default


    I really need a gxt.jar which is compiled with jdk5 .....
    There is no official jdk6 on mac osx, and even the dev preview of jdk6 doesn't work in hosted mode.

    So for now I am really blocked!

    Thanks a lot
    Roll

  9. #9
    Sencha - GXT Dev Team darrellmeyer's Avatar
    Join Date
    May 2007
    Location
    Washington, DC
    Posts
    2,241
    Vote Rating
    2
    darrellmeyer is on a distinguished road

      0  

    Default


    Beta2 will be up by Monday.

film izle

hd film izle

film sitesi

takipci kazanma sitesi

takipci kazanma sitesi

güzel olan herşey

takipci alma sitesi

komik eğlenceli videolar