1. #11
    Ext User
    Join Date
    Jun 2007
    Posts
    23
    Vote Rating
    0
    xerifa is on a distinguished road

      0  

    Default Solution

    Solution


    It worked like this...

    1) Change the MIME type to "application/x-javascript"

    2) Now HTTP 405 Resource not allowed Error in IIS error would come so, Home Directory > Configuration and From the "Mappings" tab, select the "Add" button.Click the "Browse..." button, choose "Dynamic Link Libraries *.dll" from the "Files of Type" dropdown, and select c:\WINDOWS\System32\inetsrv\asp.dll. and add "JSON" "GET,POST" verb.

    IIS would now work and read the json and treeloader would work.

    Regards


  2. #12
    Ext User
    Join Date
    Jul 2008
    Posts
    1
    Vote Rating
    0
    Rob Anderson is on a distinguished road

      0  

    Default Thanks xerifa

    Thanks xerifa


    Thank you so much for posting your solution. I also struck this problem and spent hours tring to get it to work on IIS. I knew it was IIS related because the same files worked fine on Apache.

    For ExtJS Admin: I think this fix really needs to be added to the Installation Guidelines as there are a lot of people who will want to use the Tree menu on IIS web servers and this requires additional configuration to support JSON.

    Extra note: Google (and the internal forum search) was useless in finding this post - I only found it by using Windows Live Search...

  3. #13
    Ext User
    Join Date
    Jul 2007
    Location
    Florida
    Posts
    9,996
    Vote Rating
    5
    mjlecomte will become famous soon enough mjlecomte will become famous soon enough

      0  

    Default


    Quote Originally Posted by Rob Anderson View Post
    Thank you so much for posting your solution. I also struck this problem and spent hours tring to get it to work on IIS. I knew it was IIS related because the same files worked fine on Apache.

    For ExtJS Admin: I think this fix really needs to be added to the Installation Guidelines as there are a lot of people who will want to use the Tree menu on IIS web servers and this requires additional configuration to support JSON.

    Extra note: Google (and the internal forum search) was useless in finding this post - I only found it by using Windows Live Search...
    I took it upon myself to throw together a start up guide. Feel free to add to it. Since you're "newer" you may be able to expand on it further better than I can.

    http://extjs.com/learn/Tutorial:Ext_StartUp_Guide

  4. #14
    Ext User
    Join Date
    Aug 2008
    Posts
    26
    Vote Rating
    0
    Crukkers is on a distinguished road

      0  

    Default


    Hi

    I have tried to look for this configuration in IIS7 and have come unstuck. Have you modified your approach below to work with IIS7.

    Thanks.

    Quote Originally Posted by xerifa View Post
    It worked like this...

    1) Change the MIME type to "application/x-javascript"

    2) Now HTTP 405 Resource not allowed Error in IIS error would come so, Home Directory > Configuration and From the "Mappings" tab, select the "Add" button.Click the "Browse..." button, choose "Dynamic Link Libraries *.dll" from the "Files of Type" dropdown, and select c:\WINDOWS\System32\inetsrv\asp.dll. and add "JSON" "GET,POST" verb.

    IIS would now work and read the json and treeloader would work.

    Regards

  5. #15
    Ext JS Premium Member
    Join Date
    Sep 2008
    Posts
    10
    Vote Rating
    1
    extdev22 is on a distinguished road

      1  

    Default IIS7 configuration to support JSON

    IIS7 configuration to support JSON


    IIS7 configuration to support JSON:
    Using IIS manager: clock on IIS server (the main node on the left - where you see the machine name)
    1. Add ‘json’ MIME Type
    • Double click on ‘MIME Types’ icon
    • Click ‘Add…’ link (under Actions section on the right side)
    • In ‘Add MIMI Type’ window type:
    File name extension: .json
    MIME type: application/x-javascript
    • Click OK, You should see the .json MIME Type added to the list of the MIME Types list.
    2. Add Script Map Handler for ‘json’ MIME Type
    • Double click on ‘Handler Mappings’ icon
    • Click on ‘Add Script Map…’ link (under Actions section on the right side)
    • In ‘Add Script Map’ window type:
    Request path: *.json
    Executable: C:\Windows\System32\inetsrv\asp.dll
    Name: JSON
    • Click OK (Message box pops up with a message: Do you want to allow this ISAPI extension?...etc ) Click Yes, You should see the .json extension added to the list of the Handler Mappings list

    IIS6 configuration to support JSON:
    Using IIS manager
    1. Add ‘json’ MIME Type
      • On the main IIS server right click and select ‘Properties’
      • From ‘Properties’ window in ‘MIME Types’ section click on ‘MIME Types’ button.
      • From ‘MIME Types’ window click on ‘New…’ button
      • In ‘MIME Type’ window type:
    Extension: .json
    MIME type: application/x-javascript
    • Click OK, You should see the .json MIME Type added to the list of the MIME Types.
    • Click OK to the ‘MIME Types’ window
    • Click OK to ‘Properties’ window
    2. Add Application Extension for ‘json’ MIME Type
    - On the ‘Default Web Site’ (or the site where you want to enable json for) right click and select ‘Properties’.
    - From ‘Properties window’ select ‘Home Directory’ tab if not selected.
    - Click on ‘Configuration…’ button.
    - From ‘Application Configuration’ window select ‘Mappings’ tab if not selected.
    - From ‘Mapping’ tab click ‘Add…’ button.
    - In ‘Add\Edit Application Extension Mapping’ window type:
    Executable: C:\WINDOWS\system32\inetsrv\asp.dll
    Extension: .json
    Select ‘All verbs’ on ‘Verbs’ radio button selection.
    Check ‘Script engine’ and ‘Verify that file exist’ check boxes then click OK, You should see the .json extension added to the list of Application extensions.
    - Click ‘OK’ to ‘Application Configuration’ window this will open ‘Inheritance Overrides’ window click ‘OK’ then click ‘OK’ on the Properties window.
    Important Note:
    Make sure you have Active Server Pages Allowed in the Web Service Extensions section of your IIS configuration.
    IIS6:
    IIS6 Manager -> (local computer) -> Web Service Extensions -> Active Server Pages
    Then click ‘Allow’ button.


    IIS7:
    1. from IIS7 manager click on the computer name item on the left
    2. click on “ISAPI and CGI Restrictions” icon (in IIS section)
    3. the “ISAPI and CGI Restrictions” window will show then make sure the ‘Restriction’ for ‘Active Server Pages’ is ‘Allowed’

  6. #16
    Ext User
    Join Date
    Aug 2007
    Posts
    1
    Vote Rating
    0
    spawn2u is on a distinguished road

      0  

    Exclamation IIS 5.1 Disabled OK button

    IIS 5.1 Disabled OK button


    I hope I can save someone a few minutes of searching by this little helpful tip on adding the mime type to IIS 5.1.

    I was could not get the OK button to become enabled, then I found a this http://msdn.microsoft.com/en-us/library/ms752252.aspx . Bassically if you enter all the information and then click on the file name or just click on the file name at any point and the OK button will be enabled.

  7. #17
    Ext User
    Join Date
    Nov 2008
    Posts
    8
    Vote Rating
    0
    motabo_ is on a distinguished road

      0  

    Default


    anyone using visual studio's built-in development server as an environment?

    i use visual web developer 2005 express edition - just wondering if these kinda issues will be resolved if i use the non-free 2008 version

  8. #18
    Sencha User
    Join Date
    Apr 2007
    Posts
    57
    Vote Rating
    2
    zachext is on a distinguished road

      2  

    Default


    If you're using the asp.net development server, you may need to add a custom HttpHandler for the .json files in the examples.

    Here is an example of an HttpHandler class which you would place in the App_Code folder. After adding the httphandler class to the App_Code folder, an entry for the handler is required in the web.config file.

    C#
    Code:
    using System;
    using System.Web;
    
    public class JSONHandler: IHttpHandler
    
    {
        public void ProcessRequest(HttpContext context)
        {
            context.Response.Write(System.IO.File.ReadAllText(context.Request.PhysicalPath));
        }
    
        public bool IsReusable
        {
            get { return false; }
        }
    	
    }
    VB
    Code:
    Imports Microsoft.VisualBasic
    
    Public Class JSONHandler
        Implements IHttpHandler
    
        Public ReadOnly Property IsReusable() As Boolean Implements System.Web.IHttpHandler.IsReusable
            Get
                Return False
            End Get
        End Property
    
        Public Sub ProcessRequest(ByVal context As System.Web.HttpContext) Implements System.Web.IHttpHandler.ProcessRequest
    
            context.Response.Write(System.IO.File.ReadAllText(context.Request.PhysicalPath))
    
        End Sub
    End Class
    Register the handler in the web.config file within System.Web
    Code:
    <httpHandlers>
         
          <add verb="*" path="*.json" validate="false" type="JSONHandler" />
    </httpHandlers>

  9. #19
    Ext User
    Join Date
    Feb 2009
    Location
    Ozenx 64300 France
    Posts
    17
    Vote Rating
    0
    ciait is on a distinguished road

      0  

    Default json and IIS7 layout_browser.js

    json and IIS7 layout_browser.js


    hello,

    i add the json type mime in my iis7, but it was not working
    the funny thing , that i was abble to read the tree-data.json file via http//.../tree-data.json

    i discover under firebug that the call to this file was in "POST" mode, & i was getting :
    II7 7.0 Detailled error 405.0 Method Not Allowed

    I add in the layout-browser.js line 58 : "requestMethod : "GET"

    loader: new Ext.tree.TreeLoader({
    dataUrl:'tree-data.json',
    requestMethod : "GET"
    }),


    By that way the tree-data.json is read and the data are displayed in the tree panel

    Is this "POST" method is normal when calling a static file??

    I am just discovering EXT , and congratulations for this very usefull product, .. but a beat difficult to enter in.

    Regards
    Philippe

  10. #20
    Sencha User
    Join Date
    Sep 2011
    Posts
    4
    Vote Rating
    0
    rcg is on a distinguished road

      0  

    Default


    If on IIS 7, what would you do for step 2? the asp.net dll does not exist in that directory.

film izle

hd film izle

film sitesi

takipci kazanma sitesi

takipci kazanma sitesi

güzel olan herşey

takipci alma sitesi

komik eğlenceli videolar