1. #1
    Ext User
    Join Date
    Jun 2008
    Location
    Hong Kong, China
    Posts
    29
    Vote Rating
    0
    ashleywong is on a distinguished road

      0  

    Exclamation [FIXED] "This page contains both secure and nonsecure items" in IE6

    [FIXED] "This page contains both secure and nonsecure items" in IE6


    I've tried to place the compiled Explorer or Mail app to a server running HTTPS. If I use IE6, we got "This page contains both secure and nonsecure items" alert. How can we avoid this message?

  2. #2
    Ext GWT Premium Member gslender's Avatar
    Join Date
    Mar 2008
    Location
    Brisbane, Australia
    Posts
    1,572
    Vote Rating
    2
    gslender is on a distinguished road

      0  

    Default


    This normally occurs becuase some external references exist with with blank URLs (iframes, images, stylesheets, etc) that are filled in later via script. These blanks refs can sometimes be the culprit becuase they are internally http objects when default and via script are set to a correct URL https.

    Darrell, you might need to ask Jack what they do in ExtJS and copy the same concept in ExtGWT to ensure HTTPS delivered apps work without this error.

    BTW - just my guess and I've not done any checking of the ExtGWT JS code to confirm this.

  3. #3
    Ext User
    Join Date
    Jun 2008
    Location
    Hong Kong, China
    Posts
    29
    Vote Rating
    0
    ashleywong is on a distinguished road

      0  

    Default


    I think your guess is right since I've captured the HTTP request and I found that there is no other requests beside HTTPS.

  4. #4
    Ext User
    Join Date
    Nov 2007
    Posts
    28
    Vote Rating
    0
    litera is on a distinguished road

      0  

    Default


    if you change the path of Ext.BLANK_IMAGE_URL to your own that points to http, you should be fine. And eventually also Ext.SSL_SECURE_URL if you use functionality related to these iframes.

    I don't think there are any other references within ExtJS that would point outside your domain.
    Robert Koritnik
    .net development specialist

  5. #5
    Ext User
    Join Date
    Jun 2008
    Location
    Hong Kong, China
    Posts
    29
    Vote Rating
    0
    ashleywong is on a distinguished road

      0  

    Default


    Quote Originally Posted by litera View Post
    if you change the path of Ext.BLANK_IMAGE_URL to your own that points to http, you should be fine. And eventually also Ext.SSL_SECURE_URL if you use functionality related to these iframes.
    Is it suitable for Ext GWT? Where can I set this two variables?

  6. #6
    Ext GWT Premium Member gslender's Avatar
    Join Date
    Mar 2008
    Location
    Brisbane, Australia
    Posts
    1,572
    Vote Rating
    2
    gslender is on a distinguished road

      0  

    Default


    This is someone from ExtJS background trying to answer this post - in ExtGWT these JS concepts don't exist.

    Darrell will need to consider this problem and figure out how to handle the non-urls in IFrame/images etc... it should only occur in IE6 I think so hopefully not a common problem.

  7. #7
    Ext User
    Join Date
    Nov 2007
    Posts
    28
    Vote Rating
    0
    litera is on a distinguished road

      0  

    Default


    Sorry for that. I've been reading too fast not noticing you're using ExtGWT.
    Robert Koritnik
    .net development specialist

  8. #8
    Sencha - GXT Dev Team darrellmeyer's Avatar
    Join Date
    May 2007
    Location
    Washington, DC
    Posts
    2,242
    Vote Rating
    2
    darrellmeyer is on a distinguished road

      0  

    Default


    This is already handled in GXT. See:

    Code:
    GXT.BLANK_IMAGE_URL
    GXT.SSL_SECURE_URL
    The iframe used by ModalPanel is using a secure URL. However, the shim used in Layer was not. This code was needed:

    Code:
        if (GXT.isIE && GXT.isSecure) {
          el.setElementAttribute("src", GXT.SSL_SECURE_URL);
        }
    Fix is in SVN.

  9. #9
    Ext User
    Join Date
    Jun 2008
    Location
    Hong Kong, China
    Posts
    29
    Vote Rating
    0
    ashleywong is on a distinguished road

      0  

    Default


    Has this fix released in beta5? I've tried beta5, the problem still exists

  10. #10
    Ext User
    Join Date
    May 2008
    Posts
    97
    Vote Rating
    0
    jraue is on a distinguished road

      0  

    Default


    Beta5 was released yesterday, so the SVN fix will for us non-premium users only be available with the next release. Correct me if I'm wron...