Sorry, I should have been more aware of where I was posting this question, also I did not post any details at all.
I am having the above problem with the Livegrid extension and it is extending the 2.3 editorgridpanel but I will post this question in the correct forum. I guess I was hoping for a clue when I stumbled upon this.
Thanks for your response.