It seems like package/button/button.js isn't a working substitute for javascript/yui-ext/build/widgets/Button-min.js and javascript/yui-ext/build/widgets/MenuButton-min.js. If I try to use the package, I get the (Firebug pseudo-formatted) error:

sp has no properties ext-yui-adapter.js (line 9)
apply(function(), undefined, Object)

Sorry I can't locate it more specifically, but I don't see a non-minimized version of ext-yui-adapter.js.