No argue. For me it was just annoying to have to explicitly code "after you finish this, do that, but only sometimes".
Also I was trying to make a difference between "synchronous" and "asynchronous and sequenced", "asynchronous and grouped" etc.