1. #11
    Ext User
    Join Date
    Jun 2007
    Posts
    111
    Vote Rating
    0
    Eric Suen is on a distinguished road

      0  

    Default


    Now I see what is your means, we will improve the outline view in next version
    Spket IDE - Development Tool for RIA

  2. #12
    Ext User
    Join Date
    Jun 2007
    Posts
    111
    Vote Rating
    0
    Eric Suen is on a distinguished road

      0  

    Default


    Quote Originally Posted by rarerules View Post
    Very nice!!! Could be a big help.

    One question: does this also work with Ext 1.0?
    For those who using Ext 1.0, put following code into file ext.jsb before </project>:
    Code:
      <target name="Ext Base">
        <include name="core\Ext.js" />
        <include name="adapter\yui-bridge.js" />
        <include name="yui\yahoo.js" />
        <include name="yui\dom.js" />
        <include name="yui\event.js" />
        <include name="yui\connection.js" />
        <include name="yui\animation.js" />
      </target>
    Spket IDE - Development Tool for RIA

  3. #13
    Sencha User
    Join Date
    Mar 2007
    Location
    Bah
    Posts
    434
    Vote Rating
    0
    efege is on a distinguished road

      0  

    Default


    Posted on Ajaxian today: Spket IDE: Ext Support
    Fernando G

  4. #14
    Ext User
    Join Date
    Jun 2007
    Posts
    111
    Vote Rating
    0
    Eric Suen is on a distinguished road

      0  

    Default


    Spket IDE 1.6.3 released, the code assist now support ExtJS custom class, please visit http://www.spket.com for more information...
    Spket IDE - Development Tool for RIA

  5. #15
    Sencha User
    Join Date
    Mar 2007
    Posts
    31
    Vote Rating
    0
    lastid is on a distinguished road

      0  

    Default


    Eric, I tried to update to 1.6.3, I got an error message: 'internal error: loading context' and then it seems that spket doesnt have any effects anymore.
    Here is the error in the log file.
    !ENTRY org.eclipse.core.jobs 4 2 2007-09-06 00:38:06.031
    !MESSAGE An internal error occurred during: "Loading Context".
    !STACK 0
    java.lang.NoClassDefFoundError: com/spket/js/parser/CachedLexer
    at com.spket.extjs.model.ExtLibrary.loadClasses(Unknown Source)
    at com.spket.js.model.Context$2.run(Unknown Source)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:58)

    I am using pdt eclipse.

  6. #16
    Ext User
    Join Date
    Jun 2007
    Posts
    111
    Vote Rating
    0
    Eric Suen is on a distinguished road

      0  

    Default


    Are you using Update Manager or update it manually? if you update it manually, you have to run "eclipse -clean" once, "com.spket.extjs" seems you update from a very old version, try remove following plugins manually:
    Code:
    com.spket.*1.5*
    Spket IDE - Development Tool for RIA

  7. #17
    Sencha Premium Member Iveco's Avatar
    Join Date
    Aug 2007
    Location
    Germany
    Posts
    70
    Vote Rating
    1
    Iveco is on a distinguished road

      0  

    Default


    Great,
    really nice update, thank you very much for this!
    Code completion is better now :-).

  8. #18
    Sencha User
    Join Date
    Mar 2007
    Posts
    31
    Vote Rating
    0
    lastid is on a distinguished road

      0  

    Default


    Thanks Eric, it works like a charm now.
    I removed everything and install via update manager.

  9. #19
    Sencha User
    Join Date
    Mar 2007
    Posts
    31
    Vote Rating
    0
    lastid is on a distinguished road

      0  

    Default


    Hi Eric,

    Sometimes I notice that the auto complete doesn't propose the whole list that it should be. For instance:
    Ext.get(el). [Ctrl + Spacebar] just shows an incomplete list of Ext.Element functions.
    It shows mostly animation functions like slideOn slideOut ..., but not others like createChild, insertSibling etc.

    Moreover, I cannot add templates : Window->Preferences->Spket->Editors->Javascript Editor->Templates
    Here is the error from log when I click new:
    ---
    java.lang.NoClassDefFoundError: com/spket/js/preferences/JSTemplatePreferencePage$JSEditTemplateDialog
    at com.spket.js.preferences.JSTemplatePreferencePage.editTemplate(Unknown Source)
    at org.eclipse.ui.texteditor.templates.TemplatePreferencePage.add(TemplatePreferencePage.java:547)
    ---


    Maybe I made the update not like it supposed to be.

    What should I do?

    Thanks

  10. #20
    Ext User
    Join Date
    Jun 2007
    Posts
    111
    Vote Rating
    0
    Eric Suen is on a distinguished road

      0  

    Default


    The first one is a bug, I will fix this in the next version.

    The template one I am not sure, because it work for me, what is your eclipse version and OS?
    Spket IDE - Development Tool for RIA