1. #1
    Sencha User
    Join Date
    Oct 2007
    Location
    Berlin, Germany
    Posts
    891
    Vote Rating
    9
    wm003 will become famous soon enough

      0  

    Default Errors Installing Ext Designer

    Errors Installing Ext Designer


    I tried the designer right now at work. To be able to login using my forum account (thus be connected to the internet) i need to start the application without administrative privileges.
    -> i can register, ExtDesigner asks me to continue trial -> after click, ExtDesigner closes (means no application window appears, but ExtDesigner.exe still stays in the TaskManager)

    After trying to run the ExtDesigner with Administrative privileges i cannot login, because i don't have internet access when using an admin account here at work

    I understand you need internet access to authenticate the user, but it should work without admin rights, i think. I'll try it at home later

    Just the same as jburnhams mentioned some posts above (where you assumed he still uses a preview version)

  2. #2
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,358
    Vote Rating
    127
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    @wm003 - You do not need admin rights to install or run the Designer. This was an issue we ironed out in an early pre-release. Are you behind a proxy? Do you have a group policy set?
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  3. #3
    Ext JS Premium Member
    Join Date
    Jan 2008
    Posts
    7
    Vote Rating
    0
    e4e is on a distinguished road

      0  

    Default


    Quote Originally Posted by jburnhams View Post
    I've downloaded and installed the Designer. The first time I ran it it came up with a login box, I entered my details and it went away. Nothing happened so I killed it in task manager. Now whenever I run it, nothing appears - the Ext Designer.exe process just sits there in Windows Task Manager consuming 25,840K and no CPU. Any ideas?

    UPDATE: I've uninstalled and reinstalled. On reinstall it had an error running vcredist_x86_qt.exe. Still nothing happens when I run it.
    I am experiencing the same issue with Windows 7.

    Downloaded from http://www.extjs.com/products/designer/download.php
    Installed OK.
    First start - prompted for my ExtJS Forum username and password. Successfully logged in, and then the app disappeared from the screen. Had to kill it from Task Manager.
    Second start - informed that a newer version is available. Allowed the app to download the new version, but as soon as the progress bar is shown, the app disappeared from the screen. Had to kill it from Task Manager.
    Third start - informed that a newer version is available. Didn't let the app download it and tried to continue the trial version. The app disappeared from the screen and I had to kill it again.
    Subsequent attempts with varied approaches provided the same final result - the app disappears and had to be killed from Task Manager.

    Update: Admin rights, no proxy.

  4. #4
    Ext User
    Join Date
    Sep 2007
    Location
    Porto / Portugal
    Posts
    93
    Vote Rating
    0
    pongz79 is on a distinguished road

      0  

    Default


    Same behavior here as user "e4e" but in Windows XP with SP3.

  5. #5
    Ext JS Premium Member devtig's Avatar
    Join Date
    Jan 2010
    Location
    Rotterdam, The Netherlands
    Posts
    389
    Vote Rating
    13
    devtig will become famous soon enough

      0  

    Default Need administrator priviliges as well (so it seems)

    Need administrator priviliges as well (so it seems)


    After running ExtDesigner-1.0.0-windows-installer.exe in WIndows Server 2003, I get the language selector. I click Ok. THen I get

    ---------------------------
    Error
    ---------------------------
    This installer requires administrator privileges. Please
    become administrator before executing the installer
    ---------------------------
    OK
    ---------------------------

    Update: I have no admin rights and no proxy. I am not sure how to check if I have a group policy set. I don't have the Task Manager issue that e4e, pongz79 or wm003 have.
    update2: After clicking ok, it all ends without ExtDesigner installed nor traces in my task manager.

  6. #6
    Sencha User
    Join Date
    Oct 2007
    Location
    Berlin, Germany
    Posts
    891
    Vote Rating
    9
    wm003 will become famous soon enough

      0  

    Default


    Quote Originally Posted by aconran View Post
    Are you behind a proxy? Do you have a group policy set?
    yes to both. But i could successfully register when using non-admin rights, but nothing more happens. ExtDesigner.exe just stays in TaskManager doing nothing. I made a fresh download right after abe.elias posted the official link.

    ExtDesigner even told me it had updates available 2 times. But still i cannot get anything displayed after finally clicking on "Continue Trial"

  7. #7
    Ext JS Premium Member
    Join Date
    Jan 2008
    Posts
    7
    Vote Rating
    0
    e4e is on a distinguished road

      0  

    Default


    The app works fine on another computer with XP SP3.

  8. #8
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,358
    Vote Rating
    127
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    @e4e and others, please contact me via email if you are still having issues getting this installed explaining what your exact situation is, platform, group/local policy, proxy settings, etc and we'll try to work it out for the general public.
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  9. #9
    Sencha User elnove's Avatar
    Join Date
    Nov 2007
    Location
    Canada
    Posts
    110
    Vote Rating
    0
    elnove is on a distinguished road

      0  

    Default


    I had a similar problem.
    I'm running Windows 2008 Server Standard SP1 OS, after I installed, it asked me to "continue trail", when I hit "continue" nothing happened and the designer did not start.

    I went to the control panel , and found out that I have both versions (preview and 1.0) installed, I uninstalled both of them, than reinstalled version 1.0 and it is now working.

    hope it helped.
    Live Long And Prosper \\//

    el

  10. #10
    Sencha User
    Join Date
    Mar 2010
    Posts
    4
    Vote Rating
    0
    fgilmer is on a distinguished road

      0  

    Default


    I have a pre key and designer has no place to put it in.

    It says it is still a trial version.

    Fred Gilmer