Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Ext User
    Join Date
    Apr 2007
    Posts
    50
    Vote Rating
    0
    bitdifferent is on a distinguished road

      0  

    Default [FIXED-4] Error on line 7 in designer-complete.js

    [FIXED-4] Error on line 7 in designer-complete.js


    Hi

    I've just downloaded the designer and then I did the following in this exact order:

    * added a viewport
    * set its layout to border
    * added a panel to it
    * set its region to west
    * added another panel to the viewport
    * attempted to add an Async Tree Node to the West Panel. (I get that I should have added a tree panel to the border layout but still...)

    I received this message:

    Error:

    An Error has occurred on line 7 in designer-complete.js.
    TypeError: Result of expression 'a.component'[undefined] is not an object.

    [ OK ]



    I clicked OK and all was well. But just reporting the message...

    Thanks

    Matt

  2. #2
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,198
    Vote Rating
    120
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    Thanks Matt. I've reproduced the issue. TreeNode's should have never been able to have been dragged into a Panel in the first palce!
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  3. #3
    Ext User
    Join Date
    Jan 2010
    Posts
    6
    Vote Rating
    0
    webdeveloper02 is on a distinguished road

      0  

    Question


    Also getting "An Error has occurred on line 7" message when attempting to "load data" on a datastore (see attached screenshots of error message).

    Below is the code being generated. Note that I have *****'d out part of the actual URL since it is not publicly accessible.

    Code:
    classUsersStore = Ext.extend(Ext.data.JsonStore, {
        constructor: function() {
            classUsersStore.superclass.constructor.call(this, {
                storeId: 'usersStore',
                url: 'http://*******/json/loadAllUsers',
                autoLoad: true,
                root: 'Items',
                idProperty: 'ID',
                totalProperty: 'totalCount',
                fields : [
                {
                    xtype: 'datafield',
                    name: 'ID',
                    type: 'auto'
                },
                {
                    xtype: 'datafield',
                    name: 'FullName',
                    type: 'auto'
                },
                {
                    xtype: 'datafield',
                    name: 'UserName',
                    type: 'auto'
                },
                {
                    xtype: 'datafield',
                    name: 'GroupName',
                    type: 'auto'
                },
                {
                    xtype: 'datafield',
                    name: 'Company',
                    type: 'auto'
                },
                {
                    xtype: 'datafield',
                    name: 'NoLogin',
                    type: 'auto'
                }
            ]
            });
        }
    });
    new classUsersStore();
    ..I'm also wondering:
    How does the "preview" work when calling external URLS that might require authentication? Is the underlying browser IE? FF? Other? Is there any way to set session or cookie data to work in the preview browser?

    - Neal

  4. #4
    Ext User
    Join Date
    Sep 2008
    Posts
    18
    Vote Rating
    0
    garyk is on a distinguished road

      0  

    Default


    I also get this exact same error when trying to load data into a store. It matters not if its xml, json and I have validated both.

  5. #5
    Ext User
    Join Date
    Jan 2010
    Posts
    6
    Vote Rating
    0
    webdeveloper02 is on a distinguished road

      0  

    Default


    Some additional info & screen shots:

    If I right-click on the datastore and choose "Load Data" I get the previously mentioned "Error on Line 7".

    If I select the datastore and click the "Load data" button above the listing, next to the "Add Json Store" button, I get a "Unable to load data using the supplied configuration" message.

  6. #6
    Ext User
    Join Date
    Jan 2010
    Posts
    6
    Vote Rating
    0
    webdeveloper02 is on a distinguished road

      0  

    Question


    ..and after closing out the designer, and opening it back up and loading the project again, when attempting to "Load Data" on the previously mentioned data store I now get:

    "An Error has occurred on line 7 in designer-complete.js
    TypeError: Result of expression 'delete i.dataCache'[undefined] is not an object."
    Attached Images

  7. #7
    Ext JS Premium Member prophet's Avatar
    Join Date
    Mar 2007
    Location
    Greenwich, CT
    Posts
    187
    Vote Rating
    0
    prophet is on a distinguished road

      0  

    Default


    Yeah. I'm getting the same error when trying to load a JSON Store:
    An Error Has occurred on line 7 in designer-complete.js.
    TypeError: Result of expression 'delete i.dataCache' [undefined] is not an object.



    Then, when I try to change a property on the JSON Store, like unchecking "autoLoad", I get this error:
    An Error Has occurred on line 7 in designer-complete.js.
    TypeError: Result of expression 'b' [undefined] is not an object.


    However, after I get that error, I'm able to uncheck autoLoad without getting it again... But re-checking it will bring the error message back.

    Also... when I look at the code view, it seems as if the autoLoad config option does not update to it's respective state... autoLoad will be checked on the Component Config property list, but will say "autoLoad: false" in the code.


    Hope this helps you guys.
    Brad Baumann

  8. #8
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,198
    Vote Rating
    120
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    We are looking into the errors reported on this thread.

    Quote Originally Posted by webdeveloper02 View Post
    Below is the code being generated. Note that I have *****'d out part of the actual URL since it is not publicly accessible.
    This is something that we thought of. You should use the URL Prefix configuration in Edit -> Preferences. You should use relative url configurations. This will allow you to move between dev, qa, production and domains very easily and matches a typical "handcoding" approach.


    Quote Originally Posted by webdeveloper02 View Post
    How does the "preview" work when calling external URLS that might require authentication? Is the underlying browser IE? FF? Other?
    It's a very lightweight "browser". It's webkit.

    Quote Originally Posted by webdeveloper02 View Post
    Is there any way to set session or cookie data to work in the preview browser?
    No.
    Aaron Conran
    @aconran
    Sencha Architect Development Team

  9. #9
    Sencha User
    Join Date
    Mar 2007
    Location
    Haarlem, Netherlands
    Posts
    1,243
    Vote Rating
    10
    TommyMaintz will become famous soon enough TommyMaintz will become famous soon enough

      0  

    Default


    Error:
    An Error has occurred on line 7 in designer-complete.js.
    TypeError: Result of expression 'a.component'[undefined] is not an object.
    This will be fixed in the next update.

  10. #10
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,198
    Vote Rating
    120
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    Quote Originally Posted by ExtKD View Post
    If you clear URL Prefix (e.g. if you have full URLs in config), and save it, it is reset to http://localhost/ automatically. Also after restart ot Designer it is reset to http://localhost/
    The default is http://localhost/. If you are putting full URL paths in your configurations we should not be building the urls based on the two parts. We'll fix this.

    That being said, I would suggest using relative paths in the url configurations and using the URL prefix as it was intended.
    Aaron Conran
    @aconran
    Sencha Architect Development Team