1. #1
    Ext JS Premium Member
    Join Date
    Apr 2007
    Location
    Toronto
    Posts
    20
    Vote Rating
    0
    cduicu is on a distinguished road

      0  

    Default Will Designer be kept in sync with ExtJS releases?

    Will Designer be kept in sync with ExtJS releases?


    1. How can I find out which version of ExtJS is Designer generating code for?
    2. ExtJS 3.2 is coming out soon. How will the Designer be kept in sync with ExtJS releases?

  2. #2
    Sencha - Management Team abe.elias's Avatar
    Join Date
    Aug 2008
    Location
    Palo Alto, CA
    Posts
    405
    Vote Rating
    3
    abe.elias is on a distinguished road

      0  

    Default


    We will keep them in sync to the best of our ability. When creating the Designer using Ext JS we strive to use the latest version of Ext JS (ie 3.2).

  3. #3
    Ext JS Premium Member
    Join Date
    Apr 2007
    Location
    Toronto
    Posts
    20
    Vote Rating
    0
    cduicu is on a distinguished road

      0  

    Default


    Thanks for the response.
    I would suggest that it would be a good idea to mention the ExtJS library used somewhere in the designer ("About" window would be best, but release notes would work as well).

  4. #4
    Sencha - Management Team abe.elias's Avatar
    Join Date
    Aug 2008
    Location
    Palo Alto, CA
    Posts
    405
    Vote Rating
    3
    abe.elias is on a distinguished road

      0  

    Default


    Thanks for the suggestion.

    There is a Download Ext link in the Help Menu that should direct you to the latest version of Ext.

  5. #5
    Sencha User mihaip007's Avatar
    Join Date
    Feb 2008
    Location
    Pretoria, South Africa
    Posts
    190
    Vote Rating
    0
    mihaip007 is on a distinguished road

      0  

    Default


    Hi!

    I tried that link in the help menu, but it simply goes to the following site: http://www.extjs.com/products/js/. It does not tell me what version is currently using! Can you tell me if the Build Version xds-1.0.0.8 is using ExtJS ver 3.2?

    I see that sometimes the Designer says that a new version is available and it updates! Is this when the new ExtJS is uploaded? Maybe the about part should tell what version of ExtJS is using as suggested earlier! It would help a lot

  6. #6
    Sencha - Architect Dev Team aconran's Avatar
    Join Date
    Mar 2007
    Posts
    9,100
    Vote Rating
    113
    aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold aconran is a splendid one to behold

      0  

    Default


    Yes, the designer is using Ext JS 3.2.

    I think it is a good idea to put the version in the About dialog as this question has come up frequently.
    Aaron Conran
    @aconran
    Sencha Architect Development Team