Thank you for reporting this bug. We will make it our priority to review this report.
  1. #1
    Sencha User
    Join Date
    Mar 2009
    Posts
    13
    Vote Rating
    0
    roady001 is on a distinguished road

      0  

    Default HtmlEditor grey text bug introduced in Ext 3.2 (disabled:true)

    HtmlEditor grey text bug introduced in Ext 3.2 (disabled:true)


    Unfortunately 3.2 has introduced a bug in HtmlEditor. If you start with the config 'disabled:true' and enable it thereafter, then text is displayed as grey instead of the usual black. This does not happen if you disable/enable after rendering. So if you comment the disabled:true and call the disable() from an onclick event, then the grey thing does not happen. I saw this happening in both Firefox as IE.

    Code:
    <script type="text/javascript">
    
    Ext.BLANK_IMAGE_URL = '/media/images/ext_images/default/s.gif';
    
    Ext.onReady(function() {
        var testcase = new Ext.form.HtmlEditor({
        id:'testcase',
        height:150,
        disabled:true, // BUG IN EXT 3.2! Text is displayed as grey text.
        renderTo:'test' 
        });
    });
        </script>
    
    </head>
    <body>
    <div id="test"></div>
    
    <div id="disabled" onclick="Ext.getCmp('testcase').disable();">Disable</div>
    <div id="enabler" onclick="Ext.getCmp('testcase').enable();">Enable</div>
    </body>

  2. #2
    Sencha User
    Join Date
    Mar 2009
    Posts
    13
    Vote Rating
    0
    roady001 is on a distinguished road

      0  

    Default


    I found a workaround by adding the following listener (the config option itself has to be deleted from the config object to make place for this listener of course):

    Code:
    listeners:{    
        afterrender: function(){
            Ext.getCmp('testcase').disable.defer(500,this); // EXT  3.2 bug workaround
        }
    }

film izle

hd film izle

film sitesi

takipci kazanma sitesi

takipci kazanma sitesi

güzel olan herşey

takipci alma sitesi

komik eğlenceli videolar