PDA

View Full Version : Image rendering in IE6, possible bug?



cyChop
6 Jul 2010, 11:35 PM
Hi there,

I am to develop an application that will be mainly used through IE6. The thing is, pictures appear with a border. Not only pictures I insert, but also default pictures included in GXT components. An example is the PagingToolbar:
21306

Same thing in a standard compliant browser:
21307 (Chromium here, but the same as FireFox, and what I'd wish to see in IE6)

Now is there a way to set the project so that IE6 will work out the images correctly, like an IE6 CSS hack (being forced to hack so that it works is such a shame, but still) or is it a bug inherent to GXT?

Thanks in advance!

sven
7 Jul 2010, 4:24 AM
Are you sure that there is a clear.cache.gif inside your war directory? This is required by the image bundle from GWT, not GXT.

cyChop
7 Jul 2010, 5:18 AM
Yep, quite sure. I first thought that it looked like the picture was missing (seems you had the same idea), so I browsed the URL and found a 1x1 transparent gif. Looks correct there.

I have just tested the project with IE8 on another computer, and I got no problem at all. Looks like IE6, the nightmare of web developpers, has struck again!

sven
7 Jul 2010, 5:26 AM
can you upload the application somewhere in a compiled format, so i have access to it?

cyChop
7 Jul 2010, 7:33 AM
[some private messages later, confidentiality reason - turning back in public mode, in case some other people might encounter a similar problem]

You're right sven (and my first feeling was too, I should have stuck to it).

I didn't monitor IE but turned the clear.cache.gif red. Buttons are red in Chromium but not in IE: it does not get the pic. The URL in the properties of the image is http:///. I'm gonna take a closer look. Thanks for the lead, I'll let know if I find out what's wrong.

Curious thing is, the problem only appears to occur with the IE we have at the office...