PDA

View Full Version : [FIXED-173] Designer 1.0.2 won't load my 1.0.1 project



TheCatWhisperer
9 Jul 2010, 10:27 AM
I have a 1.0.1c project that I'd been wrking on for quite a few hours, I just upgraded to 1.0.2 (and then updated to latest) and it will NOT open the project.

If I double click to project from explorer, it get the designer with a completly empty window (no properties panel, pallet, etc). at this point, it also cannot be closed & I have to kill the task.

If I open it by running the desinger, choosing new project, then file - recent projects (or open project), I get the designer with the pallet & the component tree (most of it) but it does not "draw" (ie there's no visial components to see). Note that ther are about 1/2 my components missing as well in the component tree.

Unfortunately I cannot release the app to you to take a look t (at least not through the forums).

I can tell you that the overall design was/is complex (tabs, sub tabs & layouts, grids, many stores, etc) as it is being built to replace a win32 app the company built years ago and currently uses.

If I save the project as a new file, the size of the file is 1/2 that of the original.

I am NOT looking forward to starting from scratch, we bough these Designer liscenses to SAVE time, not waste it ;)

jarrednicholls
9 Jul 2010, 10:31 AM
Hi TheCatWhisperer,

Email me your project file, jarred [at] sencha.com. I'll confirm the issue to see if it's related to a bug I'm currently working on. If not I'll get it fixed for you. I'll be releasing a new patch today with some more bug issues worked out.

I apologize for the inconvenience! Please don't start over :-) I'll get it working for you.

Jarred

P.S. Can you really whisper to cats? ;-)

jarrednicholls
9 Jul 2010, 8:04 PM
Hi Cat,

Please upgrade to 1.0.2.2 to see if your problem has been resolved. If not, the sooner you can email me your project file, the sooner I will be able to diagnose the issue and resolve it for you and anyone else who may be having a similar problem.

Thanks much, and have a great weekend!

Lod
12 Jul 2010, 8:03 AM
My colleagues who are using Ext Designer encountered the same problem after upgrading.

lombardo
12 Jul 2010, 8:13 AM
Hi Jarred,
i have the same problem, i can't open my project ..............i only see the first component

jarrednicholls
12 Jul 2010, 9:53 AM
I have received a project file from another user having trouble opening their project, and I will be working to resolve this issue today. I will deploy an upgrade with a fix ASAP. You can check this thread, and when it is marked "FIXED", then it is staged and ready for the next release. In the meantime, if you are able to donate your project file here on the thread, then I can be sure the issue is worked out in your particular case. Sorry for the inconvenience.

lombardo
12 Jul 2010, 11:20 AM
Jarred,

I attach my project.

I canīt open in 1.0.2.2

jarrednicholls
12 Jul 2010, 11:40 AM
Thank you lombardo...I think I have identified the issue for sure. This is fixed for the next release. It has to do with progress bars in 1.0.1 project files. I will be releasing a new version soon. Thanks for your patience.