PDA

View Full Version : Linked component gets unlinked



toddgeist
12 Jul 2010, 8:48 PM
Mac OSX 10.6.4
Safari 5, Firefox 3.6

I noticed that my linked component was appearing twice. this is what it looked like

http://screencast.com/t/MWE1NDA1NTg

Then I noticed that the Link graphic line that connects the linked object to its top level component was missing. I checked the xds_index.js file and sure enough the linked component was being rendered on its own. You can see an example here.


Ext.onReady(function() {
var cmp1 = new Artisan({
renderTo: Ext.getBody()
});
cmp1.show();
var cmp2 = new PatientForm({
renderTo: Ext.getBody()
});
cmp2.show();
});

cmp2 should not be there.

I quit Ext Designer, relaunched it, and the link graphics line with arrows was back. I re-exported the project and all was well. Here is another screencast that might help explain it.

http://screencast.com/t/Yzg5MDFjNW

Thanks

Todd

jarrednicholls
13 Jul 2010, 5:54 AM
Hi Todd,

Do you know how to cause an "unlink"? I was expecting...or hoping?...to see that in the second screencast but I saw "as expected" behavior. In the meantime I'll see if I can find out myself.

Thanks.

toddgeist
13 Jul 2010, 7:28 AM
I knew you would want to see that.;)

I do not know what caused it. I have since been hammering away on designer and it has not happened again. But it clearly did happen. Restarting Designer restored it.

If it happens again I will try to figure out what did it.


Thanks

Todd

jarrednicholls
13 Jul 2010, 7:29 AM
Believe me that I believe you...I just wish I knew how to make it happen also :-) I'll keep trying as well...Thanks!