PDA

View Full Version : Reg. Ext Direct MVC



After2050
17 Sep 2010, 2:18 AM
Hi,

I'm using Ext Direct API for communicating with my ASP.NET MVC server. There are situations where the request takes more time to complete. But, what I see is after a particular time the request is getting aborted and another request is firing from the client.

How I can increase the time limit in web.config?

In the below case.. can I able to specify the time for a single call,

MyController.MyMethod(params, function(request, response){
});

Dnana | Trigent

steffenk
17 Sep 2010, 2:55 AM
you could configure Ext.data.Connection and timeout property.
Anyway you should optimize server side as requests shouldn't take too much time.

After2050
20 Sep 2010, 12:16 AM
Hi Steffen,

Thanks for your suggestion. I made changes to my server-side scripts to avoid timeout issues.
This is my current configuration.

<ext.direct
providerName="Ext.app.REMOTING_API"
assembly="WebAssembly"
dateFormat="Iso"
debug="true"
/>

Ho I can specify the timeout property?

Dnana | Trigent

steffenk
20 Sep 2010, 1:49 AM
hi,

i have no idea for ASP. But have a look to Ext.direct.RemotingProvider, it has a timeout property.
http://dev.sencha.com/deploy/ext-3.3-beta1-6976/docs/?class=Ext.direct.RemotingProvider&member=timeout

After2050
21 Oct 2010, 2:58 AM
Finally I got the solution.

Ext.app.REMOTING_API.maxRetries = 0; //setting the maximum no. of retries
Ext.app.REMOTING_API.timeout = 1000000; //setting the timeout value

Ext.Direct.addProvider(Ext.app.REMOTING_API);

Thanks for this thread (http://www.sencha.com/forum/showthread.php?80086-FIXED-239-3.0r5286-several-Ext.Direct-bugs-(Timeout-failure-actionfailed))