PDA

View Full Version : Datefield problem icon validation (IE)



vCastro
27 Sep 2010, 3:38 AM
Hello,

I have a problem with the validation icon in DateFields. The icon is superimposed on the datepicker. This behavior is not happening in FF but in IE and Chrono exists.

i use gxt 2.0.1.

can anybody help me.

Best regards

VCastro

sven
27 Sep 2010, 3:42 AM
You should tell us something more than this. Where is your datefield located? Is it somehow hidden while validating happens? For example in a non active tabitem?

vCastro
27 Sep 2010, 3:49 AM
i'm trying to attach an image to this post but the upload doesn't seem to be working.

Datefield is on layout container.

I'm not hiding the datefield, my code is






FormLayout layout = new FormLayout();
layout.setLabelAlign(LayoutConstants.LABEL_ALIGNMENT);
layout.setLabelWidth(LayoutConstants.LABEL_WIDTH);
layout.setLabelPad(LayoutConstants.LAYOUT_PADDING);
validityLayoutContainer = new LayoutContainer();
validityLayoutContainer.setLayout(layout);

beginDate = new MergeDateField();
beginDate.getPropertyEditor().setFormat(DateTimeFormat.getFormat(BusinessConstants.DATE_TIME_FORMAT));
beginDate.setName(BindingNames.PROMOTION_BEGIN_DATE);
beginDate.setFieldLabel(constants.promotion_data_ini());
beginDate.setAllowBlank(false);

validityLayoutContainer.add(beginDate);

sven
27 Sep 2010, 3:53 AM
And where do you add the validityLayoutContainer into?

I'm not hiding the datefield, my code is
Are you hiding or collapsing any parent?

vCastro
27 Sep 2010, 5:51 AM
No. I just add one to the DateField layoutcontainer. But neither parent or any layout is hidden or minimized.

sven
27 Sep 2010, 6:00 AM
No. I just add one to the DateField layoutcontainer. But neither parent or any layout is hidden or minimized.

Can you please post a fully working testcase of your problem that implements EntryPoint and is runnable by others without any depencies?

vCastro
27 Sep 2010, 6:20 AM
I can not post this information because there are many dependencies in my project.

But you think that the problem that exists is related to a container is being hidden?

sven
27 Sep 2010, 6:23 AM
I can not post this information because there are many dependencies in my project.
You should try to reproduce this problem in a small standalone testcase. Else it is really hard to help you.


But you think that the problem that exists is related to a container is being hidden?
That is normally the cause for what you are describing. At least how i understand it.

vCastro
27 Sep 2010, 8:07 AM
But if this only happens in ie or chrome, so there must be a problem.

My layout container is connected to a tab item, however it is active.

Using the developer tools ie, the case adding the css class = <img gwt-Image> the tag <margin-left 16px> the icon is now placed in the right place