View Full Version : visibility:hidden, instead of display:none ?!?

5 Oct 2010, 9:32 AM

I'm having a weird issue. Elements are being written with "visibility:hidden" instead of "display:none".

This is causing display issues cause items are blown out, because visibility hides the element, but doesn't collapse the bounding box.

Ive created a few apps with EXT, and never seen this before. Makes me think I accidentally triggered some base level setting somewhere on my current app maybe?


5 Oct 2010, 11:17 AM
Try to see if there is a hideMode config somewhere.

hideMode (http://dev.sencha.com/deploy/dev/docs/source/Component.html#cfg-Ext.Component-hideMode) : String
How this component should be hidden. Supported values are 'visibility' (css visibility), 'offsets' (negative offset p...
How this component should be hidden. Supported values are 'visibility' (css visibility), 'offsets' (negative offset position) and 'display' (css display).

Note: the default of 'display' is generally preferred since items are automatically laid out when they are first shown (no sizing is done while hidden).

5 Oct 2010, 11:52 AM
Thanks for the reply.

I did a global find on all JS files, to see if any "hideMode"s were out of place. There weren't any set to "hidden".

Seems like this would be it, but how would you assign a hideMode to a Ext.Msg.confirm box's textfield and textarea. Those are there for the prompt, but hidden for confirm.

There is no hideMode setting for a Msg.confirm box's internal components that i know of... So no idea how it is defaulting to "hidden".

Pulling my hair out here =)

5 Oct 2010, 12:02 PM
Tracked it down to a "ManagedIFrame" plugin... removed that, and everything is fine... its all minified, so hard to see what exactly inside it is causing it tho.

Thanks for the help again

6 Oct 2010, 1:40 AM
You were using a ManagedIframe for Ext 2.x in Ext 3.x. When upgrading Ext you often also need to upgrade all extensions and plugins you use.