PDA

View Full Version : [DUPE] Unable to preview the project but ok to design and export



ggierer
13 Dec 2010, 7:15 PM
Designer version tested:

Build Version xds-1.0.2.14

Operating System:


Windows 7 Pro 64bit

Description:

The attached project file works perfectly in design mode but I am unable to preview the project. Note that exporting is fine and each individual panel displays fine in preview window.

Steps to reproduce the problem:

open the attached project file in Ext Designer and try to preview

The result that occurs instead:

nothing is displayed in the preview window. Individual components preview fine.

honzakuchar
22 Dec 2010, 5:19 AM
For me, completely same. And when you put all linked components together into one, it will work ok.

jarrednicholls
22 Dec 2010, 6:04 AM
I'll take a look at the project file. The preview is much like viewing it in a live browser...if it's broken in Preview, then it's broken in a live browser.

The most common reason is GridPanels that have no stores bound to them. If you have GridPanels, and they don't have a Store, it's broken. You get a warning on export for missing store configurations for a reason...the GridPanel will throw an error when it's initializing and the components will stop rendering resulting in a broken view. Even if it's a dummy store, you should configure all GridPanels with a store. In Design view, the Grid gets a store no matter what just so it renders for you :) We'll consider the same for Preview, though it has some value seeing it break in Preview because you know it will break in the browser too.

The easiest thing to do is to view the component in a browser with a debugging console (Firefox + Firebug, Safari/Chrome + Web Inspector, etc.) and check for JS errors. They are quite helpful in figuring out errors.

dchristensen
21 Jan 2011, 2:29 PM
Same issue here, but I don't think it's a problem with the grid or a store. I can see the data in the Design view, but the Preview window is blank as well as the export (which also works BTW.)

Also, the Design view doesn't show all of the components in the second Tab (layout: 'fit'). I have a GridPanel and a FormPanel - one above the other. If I select the FormPanel in the "Components" tree, it shows the form and part of the GridPanel (rows 1 & 2 are shifted up out of view.)

JonasTG
30 Mar 2011, 4:46 AM
Hello, I have a similar problem with a custom component that I created, it contains a combo with a store bound (xmlstore, but directstore for test). The problem is that if I preview te component it runs fine, but if I preview the entire component hierarchy it crash (but not the exported project in localhost server preview).

Any solution??

Attach the demo prject: 25416

jarrednicholls
6 Apr 2011, 6:01 AM
I'll take a look into this today.