PDA

View Full Version : Tree elbow images



extDev
13 Dec 2010, 11:19 PM
Hi everybody,

23798

I have a tree panel and lots of tree nodes in it. Everything is working fine expect there is a little problem. In the attached screenshot, my tree nodes do not have elbow images and loading gif is just behind the node icon. (in this screenshot loading gif is behind the Menu node's icon) What is the problem. How can I fix this little glitch?

PS: Here is some elbow images. 2379923800

Thanks in advice.

Fatih

arthurakay
14 Dec 2010, 6:01 PM
Do you have "lines" set to false on your TreePanel config? It should default to true, which displays the lines.

If that isn't the issue, what does FireBug tell you? Do you see any problems with your CSS? (Turn on CSS errors). Also, is this issue limited to a particular browser?

If none of that solves the problem... are you overriding anything relating to TreePanel? Post some code.

extDev
15 Dec 2010, 2:10 AM
Yeah, what a mistake. I have a base tree and every tree is extended from base tree. And in base tree there was a property
lines: false
I removed that and it's worked. But node loading gif is still behind the node icon. Any solution?

Thanks arthurakay

mankz
15 Dec 2010, 2:23 AM
How does your CSS class look that sets the icon?

lucas231988
16 Oct 2012, 5:59 AM
Hi mankz, I am having the same problem with version 3.0 and I did set "lines" to false but still having the problem ... Do you have any other idea what could it be ? Thank you very much