View Full Version : Sencha Touch stopped working on iPad

21 Dec 2010, 1:20 PM
I've been developing a Sencha Touch app for iPad and it suddenly stopped firing the ready event off of Ext.setup. Javascript was still working (i could get console and alerts outside of the ready function). I tried multiple projects including just a ready function wrapping a console.log statement. None worked. Links saved to the home screen continued to work. I eventually hard restarted the iPad which fixed the problem.

Is this a known issue?

21 Dec 2010, 1:27 PM
did you check if you have (syntax) errors? open your app in safari or chrom and check if you have errors in webinformation panel

21 Dec 2010, 1:31 PM
It worked fine on the desktop. It was only on the iPad. There were no errors in the iPad safari debug log.

I tested multiple projects including this simple code:


onReady: function()

I would see the init log message but not the ready message. It seems like something freaked out in the browser and the document wasn't raising the ready event until I restarted.