View Full Version : Running Compass on Linux gives "no such file to load"

Fredric Berling
22 Dec 2010, 2:04 AM
I recently moved my project from a Mac to a Linux server. Now i have trouble compiling the CSS with compass.

When in the "resources/scss/" directory i run the following command:

$ compass --update

Loading haml-edge gem.
LoadError on line 5 of /var/www/private/MVC/resources/scss/config.rb: no such file to load -- /var/www/private/MVC/resources/scss/../../lib/touch/resources/themes
Run with --trace to see the full backtrace

This is the line where to include the sencha framework. The ruby code for this in config.rb is:

# Load the sencha-touch framework automatically.
load File.join(dir, '..','..', 'lib', 'touch', 'resources', 'themes')

The "file" it does´s seem to find is actually a folder but do exist in that path
Any ideas about this?

22 Dec 2010, 11:02 AM
hmmm, I have different config and results.

running sencha 1.0.1 on ubuntu 10.04



# Get the directory that this configuration file exists in
dir = File.dirname(__FILE__)

# Load the sencha-touch framework automatically.
load File.join(dir, '..', 'themes')

# Compass configurations
sass_path = dir
css_path = File.join(dir, "..", "css")
environment = :production
output_style = :compressed

22 Dec 2010, 11:05 AM
for application specific scss I have:




sass_path = File.dirname(__FILE__)
css_path = File.join(sass_path,'..','..','media','css')
images_dir = File.join(sass_path,'..','..','media','sencha','resources','themes','images','default','pictos')
load File.join(sass_path,'..','..','media','sencha','resources','themes')

output_Style = :expanded
environemnt = :development

22 Dec 2010, 11:08 AM
In order to get compass to work correctly for me I had to add it to the PATH or call it directly. To do this I added the following line to my .bash_aliases file:

alias compass='/var/lib/gems/1.8/bin/compass'

this file is imported in my .bashrc

22 Dec 2010, 11:13 AM
Also, I run

compass compile

compass --update gives the following error

WARNING: This interface is deprecated. Please use the new subcommand interface.
See `compass help` for more information.

exists ../../media/css

You should make sure your compass is installed and up to date. try

compass --version

compass version

to make sure everything is installed correctly

I apologize for the stream of consciousness posting :>

22 Dec 2010, 3:29 PM
I'm working on this server with Fredric and I fixed this problem. In case anyone else gets this, the problem was that I installed an outdated version of Compass (0.8.17) from chriseppstein-compass that is incompatible with haml 3.0. Running

gem uninstall chriseppstein-compass
gem install compass

fixed the problem. See http://groups.google.com/group/compass-users/browse_thread/thread/6816d0f328031d64 .

gcallaghan, thanks for the help. Your posts were useful while I was troubleshooting this.