PDA

View Full Version : Problem with disabled form elements in IE8



mc_giangi
21 Feb 2011, 9:13 AM
Hi, I have two panels (form panels). The first has the config "hidden: false", the second "hidden: true". They have the same content (comboboxes and spinnerfields). When the page is rendered in IE 8 (only in IE), the disabled items of the first panel are shown correctly. This not happens when the second panel is shown (by the show() method). Its disabled items are not displayed in the right way (the buttons disappear or the fields disappear). Is it a bug of ExtJs??? Someone can help me please?
Excuse me for my bad english...

thanks in advance...

24780

mc_giangi
24 Feb 2011, 2:17 AM
Can someone answer to my question please??? :((

Condor
24 Feb 2011, 2:26 AM
I'm not sure if you should call it a bug in Ext, because it's caused by a bug in IE.

Have you tried configuring the second panel with hideMode:'offsets'?

mc_giangi
24 Feb 2011, 3:04 AM
Yes, I did...but it's the same...I solved the problem by hiding the panels after the render (using the hide() method)...it's ok but it's not the best solution. Do you know a better method to solve this bug (of IE ;))?

thanks, Gianluca.

ikokostya
1 Mar 2011, 4:38 AM
I have the same problem.

aramaki
4 Mar 2011, 2:39 AM
try to add next css rule
.x-item-disabled {
width:auto !important;
}

mc_giangi
4 Mar 2011, 6:28 AM
It isn't the width the problem...probably we're not talking about the same extJs bug...however, thank you.

aramaki
4 Mar 2011, 7:59 AM
I have got the same problem and resolve it by above method via css. try to investigate html that ext js generate for combo. div element which contain combos inputs have inline width: 17px but this width is override in another class. it`s not working in ie8 (I don`t no why)

mc_giangi
4 Mar 2011, 8:10 AM
It doesn't work for me...it's not a width problem....

aramaki
4 Mar 2011, 8:11 AM
could you post combo config here?

mc_giangi
4 Mar 2011, 8:22 AM
No, I can't...sorry...I solved my problem in another way. If I render the panels and, afterrender, I hide them...they work correctly...but I want to find a better way to solve this problem. I know it's not easy without the code.

jagadeesha
25 Nov 2012, 11:48 PM
.x-item-disabled {
filter:'' !important;
}

This worked for me :)

willigogs
26 Nov 2012, 12:15 AM
Please don't keep posting the same thing repeatedly, especially when this thread has been dead for 18 months, and you don't even know how your posted code works!!!

jagadeesha
26 Nov 2012, 8:12 PM
True sorry for repeated replay (I could not realize it's submitted twice).

Sometimes it's enough to know whats the solution is instead of thinking how it works :).

Because i too have searched for this solution for a long time in the forums but no luck then with my 2 day's effort am able to find out this solution.

Your seeing only two lines of solution here but you should also think the efforts behind to get these two lines too.:)

It's not an easy topic to explain about css filter's . moreover i dont want user's to get confused with the solution with all those details, thats secondary.

For your info these are the few resources that i have used to get these solution

http://www.html5rocks.com/en/tutorials/filters/understanding-css/

http://www.html5rocks.com/en/tutorials/filters/understanding-css/

http://en.wikipedia.org/wiki/CSS_filter

Thanks for the replay.