View Full Version : MVC Naming Convention

21 Mar 2011, 5:47 PM
Is there a specific naming convention required for MVC?
If yes, where can I learn more about it?

Also in general, is there a specific naming convention for sencha touch for filenaming, function and variable names, etc? Or should I just follow Javascript naming convention?


21 Mar 2011, 7:10 PM
I simply follow the naming convention from here:
And if in doubt, just do things as per normal javascript, eg camelCase for instance variables, and PascalCase for namespaces and class declarations.

21 Mar 2011, 7:40 PM
Ok thanks.

Just that I'm trying to debug an error, just wanted to eliminate the possibility of it coming from false naming. Also good to pick up good habits from early on since I'm only just a beginner at this stage.