PDA

View Full Version : Running ST/Phonegap MVC Tutorial on Android fails



MrRoyce
22 Mar 2011, 2:58 PM
Hi there, after a bit of a struggle with XCode, etc, I finally got the ST MVC tutorial to run correctly in the iPhone IOS simulator.

I'm trying to port the tutorial to Android, but its not working. I can get as far as the ContactList.js view to display the title ('Contacts'), but thats it. No contacts are displayed (I have lots of contacts on my phone and added several to the Android simulator). As far as I can tell, all the contacts are being correctly read from the address book in the model (Contact.js). But someplace in the handofff back to the view, the records are being lost/mangled/something.

Its almost impossible to do decent debugging to trace back through the ST Framework to see where things are going wrong. I was able to do some primitive logging and alerts, but that doesn't help to pinpoint the issue.

I am using PhoneGap 0.94 and ST 1.01 as well as Eclipse and the MDS 1.1 Eclipse Phonegap plugin (APPLaud).

Has anyone else tried this? Any help is appreciated.

fermina
22 Mar 2011, 8:47 PM
I have the same problem.
I can see the Contacts data in Android simulator. But, I don't see any data in my phone.
I'm using PhoneGap 0.94 & Sencha Touch 1.0.2.
My phone is Samsung Gallaxy S.

azfrederick
9 May 2011, 8:20 AM
I am having the same issue and it's failing in the same spot, when I try to initialize Contact contacts. I even commented out the PhoneGap portion that retrieves the contacts and still don't get anything to show up on the screen (just white).

Has anyone successfully got this to work with Android? Could the AndroidManifest.xml be setup wrong?

azfrederick
9 May 2011, 12:19 PM
Actually, does anyone have a zip file of an Android project they have running with ST and PhoneGap for Eclipse?