View Full Version : misleading variable name in Ext.lib.Component function addListener

29 Mar 2011, 9:32 AM
1.1.0 sencha-touch-debug-w-comments.js line30438 for Ext.lib.Component reads

addListener : function(element, listeners, scope, options) {

and if you look inside the function is seems it should be like what online doco says

addListener( String eventName, Function handler, [Object scope], [Object options] ) : void

obviously without void etc.

It is just really confusing that what is eventName apparently erroneously is called element, but there is actually another element used in the function.