PDA

View Full Version : [OPEN] SenchaSDKTools-1.0 on CentOS 5.6



vpopa
26 Apr 2011, 7:46 AM
I want to create a jsb3 file on CentOs 5.6 - 64.
After I downloaded the 32 bits version I had to do some editing to hardcode the path to the executable files(jsdb, ext-app-builder). I've got similar errors with the 64 version that I've also tried.
I was getting error messages like this one:
/opt/SenchaSDKTools-1.0/command/sencha: line 3: jsdb: command not found
or
sh: ext-app-builder: command not found
But this was the easy part.

Then I run into this error
./phantomjs.bin: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by ./phantomjs.bin)

I know that CentOs is using an older version of GCC Standard C++ Library package. It's is possible that you guys add support for oder versions of glibc? Or is there something I can do to make it work(except change the os) ?

Thz,
Vali

jarrednicholls
27 Apr 2011, 11:25 AM
Hi Vali,

That is very strange for CentOS 5.6 (release this month) would not have glibcxx 3.4.9, which is fairly old. We will be certain to release a version compatible with older glibc and glibcxx versions. We'll work towards CentOS 5.6 compatibility for sure. In the meantime, you can download an rpm of libstdc++ and install a newer version on your system. It shouldn't be a problem for any of your distro software builds, because glibc and glibcxx are binary backwards compatible.

As for your pathing issue, I don't understand how or why that was an issue. The installer places the installation target in the front of your PATH environment variable. It shouldn't have had any troubles locating those executables...very strange.

Thanks for reporting the issue.