PDA

View Full Version : [INFOREQ][4.0.1] combo layout anomoly when in strict mode



slemmon
19 May 2011, 6:30 PM
In IE in strict mode I'm seeing the trigger rendered under the combo field. The combofield is an item in a toolbar and is the only item. I can drop the doctype and refresh the page and the trigger renders correctly. Add the doctype of strict back in and the trigger renders underneath.

26163

IE used: 8.0.6001.18702CO
http://www.sencha.com/forum/images/misc/pencil.png

slemmon
19 May 2011, 6:49 PM
Looks like the zoom in the browser was at 95% if that helps. Once I moved it up to 100% render in strict and no doctype was fine.

evant
19 May 2011, 9:21 PM
I can't reproduce this, using the following:



Ext.onReady(function(){

Ext.create('Ext.form.Panel', {
width: 400,
height: 200,
renderTo: document.body,
dockedItems: [{
xtype: 'toolbar',
items: {
xtype: 'combo',
store: [1, 2, 3, 4, 5]
}
}]
});
});

evant
19 May 2011, 9:22 PM
Image:

slemmon
20 May 2011, 12:13 PM
Hmm... not sure. I tried just now using the sample code you used and was still seeing the trigger rendering underneath the field when using IE8. I did a reset to factory in IE options just to be sure.

Here is the code:



<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

<html>
<head>
<title>Ext test</title>

<link rel="stylesheet" type="text/css" href="../javascript/ext4/resources/css/ext-all.css">

<link rel="stylesheet" type="text/css" href="resources/css/nabors.css">

<script type="text/javascript" src="../javascript/ext4/ext-all.js"></script>

<!-- <script type="text/javascript" src="resources/ux/TDGi.iconMgr/TDGi.iconMgr/TDGi.iconMgr.js"></script> -->

<style>
.icon-asterisk_orange {
background-image:url(resources/images/asterisk_orange.png) !important;
}
</style>

<script>
Ext.onReady(function(){

Ext.create('Ext.form.Panel', {
width: 400,
height: 200,
renderTo: document.body,
dockedItems: [{
xtype: 'toolbar',
items: {
xtype: 'combo',
store: [1, 2, 3, 4, 5]
}
}]
});
});
</script>


</head>
<body></body>
</html>


And here is my screenshot:
26185

IE used: 8.0.6001.18702CO