PDA

View Full Version : [OPEN] ComboBox shadow/loadingText property causes warning/error in compat-mode



viadev
30 May 2011, 5:24 AM
Hi there,

my compat mode says "[DEPRECATED][4.0][Ext.form.field.ComboBox] shadow (config): Use listConfig.shadow instead." when i am trying to create a ComboBox. i've done a little investigator work because i am not using this shadow-thing in my config so i was wondering where does it comes from.

I figured out that this shadow-thing comes from "Ext.define('Ext.util.Floating'..." (ext-all-debug).
You can find this member variable directly in Ext.form.field.ComboBox but the compat mode wants it to be in ComboBox.listConfig.shadow. So the compat-mode copies the member variable to listConfig and deletes the other.

So is this a bug?

The other warning/error comes from ext-lang-de.js where the loadingText-property is also apply to ComboBox. compat-mode wants it to be in listConfig.loadingText.

A bug too?

Thanks

mberrie
31 May 2011, 4:39 AM
"[DEPRECATED][4.0][Ext.form.field.ComboBox] shadow (config): Use listConfig.shadow instead."


This has been mentioned on the migration thread (http://www.sencha.com/forum/showthread.php?124015-Ext-3-to-4-Migration&p=600932&highlight=shadow#post600932) before. It is confusing but not harmful ;) Once you remove the compatibility layer you are fine.

If the message annoys you, consider commenting out this line in compat.js



remapToListConfig('shadow', 'shadow');