View Full Version : Destroy method isn't working properly...

31 May 2011, 9:27 PM
Destroy method is not removing the refernce....even remove is not working for x-panel type reference......

remove is removing the component from parent panel very properly but not removing the reference...its reference exist even after removing the component from parent...remove is just setting the isDestroyed property to true..

if i continue without destroying or removing...... i get Uncaught-TypeError-Cannot-read-property-className-of-undefined error....while dragging draggable items on the page....

if i tried opening that page directly....then its working fine......if tried opening with last page reference then i got Uncaught-TypeError-Cannot-read-property-className-of-undefined

plzzz suggest...

3 Jun 2011, 2:48 PM
Could you create a test case for this issue please?


18 Sep 2012, 5:04 AM
I think the issue is that either the draggable or droppable objects are still registered as listeners, and they are trying to modify the class of their respective dom elements even though they don't exist anymore. I had a similar situation but doing panel.droppableObject.disable() did it for me (droppableObject a reference I added).