PDA

View Full Version : Ext is undefiend when trying to Log from Citrix + SSO (Citrix without SSO works fine)



daniel_r
10 Jun 2011, 12:35 AM
Hi

My web app runs on tomcat server, The clients are conncting from Citrix stations with SSO (wich runs on Apache , port 80), they can also log in without SSO by using the 8080 port (tomcat)

When the client try's to connect with the SSO (port 80) the web app works fine, except for the pages which includes the EXT js files, on that pages a js error pops up with the "Ext is undefiend " message :/, all the other pages are being loaded just fine

If the client logs to my web app without the SSO (by using the 8080 port) all the pages are being loaded fine - including the pages which includes the EXT js files,

I realy got not even the slightest idea on what could be gone wrong with my web app, and how the SSO can conflict with the EXT js files...

Any idea will be much appriciated,

Thanks ahead,

Daniel.

mankz
11 Jun 2011, 11:31 PM
Hmm hard to help without seeing code. Can you paste your rendered Html page and JS?

daniel_r
11 Jun 2011, 11:40 PM
Thanks ,

Here is the entire html page code (not the rendered one, Its happening to one of our client, and I don't have access to that :/)



<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<!--Ext and ux styles -->
<link type="text/css" rel="stylesheet" href="../../../ExtJS/ext-3.3.1/resources/css/ext-all.css"/>
<link href="../../../ExtJS/ext-3.3.1/examples/ux/css/LockingGridView.css" rel="stylesheet" type="text/css" />
<link href="../../../ExtJS/ext-3.3.1/examples/ux/css/Spinner.css" rel="stylesheet" type="text/css" />

<!--Gantt styles-->
<link href="../../css/sch-gantt-all.css" rel="stylesheet" type="text/css" />

<!--Implementation specific styles-->
<link href="../../css/examples.css" rel="stylesheet" type="text/css" />
<link href="bcp.css" rel="stylesheet" type="text/css" />

<script language=javascript src="../../../Templates/Assets/Server.js"></script>


<script language=javascript src="../../../Templates/Assets/Utilities.js"></script>
<script language=javascript src="../../../Templates/Assets_UI/Module.js"></script>


<!--Ext lib and UX components-->
<script type="text/javascript" src="../../../ExtJS/ext-3.3.1/adapter/ext/ext-base.js"></script>
<script type="text/javascript" src="../../../ExtJS/ext-3.3.1/ext-all-debug.js"></script>
<script type="text/javascript" src="../../../ExtJS/ext-3.3.1/examples/ux/LockingGridView.js"></script>
<script type="text/javascript" src="../../../ExtJS/ext-3.3.1/examples/ux/Spinner.js"></script>
<script type="text/javascript" src="../../../ExtJS/ext-3.3.1/examples/ux/SpinnerField.js"></script>


<!--Gantt components-->
<script src="../../js/sch-gantt-base-debug.js" type="text/javascript"></script>
<script src="../../js/sch-gantt-all-debug.js" type="text/javascript"></script>



<!--Application files-->
<script src="BCPScenarioGantt.sch.gantt.plugins.taskcontextmenu.js" type="text/javascript"></script>
<script src="BCPScenarioGantt.sch.gantt.tooltip.js" type="text/javascript"></script>
<script src="demo-BCPScenarioGantt.js" type="text/javascript"></script>
<script src="BCPScenarioGantt.js" type="text/javascript"></script>
<script src="sch.gantt.viewpresets.js" type="text/javascript"></script>


<!--Patch's -->
<script src="Patch_FIXED_1158_3-2.js" type="text/javascript"></script>
<!-- <script src="[1.8]_getting_null_is_null_or_not_an_object.js" type="text/javascript"></script>-->


<title>BCP Gantt</title>
</head>
<body>
<div id="north">
</div>
</body>
</html>
Thanks again!

mankz
11 Jun 2011, 11:56 PM
No idea I'm afraid, haven't tried running Ext on such a SSO config setup before. Perhaps some firewall/security issue with the js files?