PDA

View Full Version : [4.0.2] isIE7 returns true for ie8



wiz61
14 Jun 2011, 6:51 AM
I do a test for Ext.isIE6 and Ext.isIE7 (just checking each property for true) in order to inform the user to upgrade. It works fine, except that Ext.isIE7 also returns true for IE8.

evant
14 Jun 2011, 6:52 AM
Are you running in compat mode?

wiz61
14 Jun 2011, 6:57 AM
The default is to view all intranet sites in compatibility mode, so yes (this is an intranet site). I can understand the issue, though it should be noted in the docs, which is the real reason for the post (it's not that big a deal for my project).

wiz61
14 Jun 2011, 7:00 AM
Actually, I can't really tell. The tools menu has "compatibility view" grayed out. I assumed that this means it is in that mode and can't be changed, but the icon (the broken page) is not showing anywhere.

ValterBorges
14 Jun 2011, 9:08 AM
do a view source and look for a meta tag that forces the browser into ie7 compatibility mode, it will disable the compatibility view

wiz61
14 Jun 2011, 9:31 AM
Thanks. I was able to code around it. As stated above I posted this thread more for a documentation heads up. The Ext.isIEx properties should have this caveat noted.