PDA

View Full Version : How to avoid the IE security warning (Solved) ?



crocobit
26 Dec 2006, 11:49 AM
I am trying the array-grid example and the Yellow Bar of IE stop my javascript.

http://img240.imageshack.us/img240/7161/barraut0.jpg

Help me please.

My code is:


<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<script type="text/javascript" src="lib/YahooUI/utilities/utilities.js"></script>

<link rel="stylesheet" type="text/css" href="lib/resources/css/reset-min.css" />
<link rel="stylesheet" type="text/css" href="lib/resources/css/grid.css" />

<script type="text/javascript" src="lib/yui-ext.js"></script>
<script type="text/javascript" src="array-grid.js"></script>

<link rel="stylesheet" type="text/css" href="lib/examples.css" />

</head>
<body>

<div id="example-grid" style="border: 1px solid #cccccc; overflow: hidden; width: 535px; height: 225px;"></div>

</body>
</html>


Thanks

C.B.

jack.slocum
26 Dec 2006, 3:12 PM
I have no clue. There isn't any pop ups in that example.

crocobit
26 Dec 2006, 3:39 PM
What i mean is that Yellow Bar:

http://img240.imageshack.us/img240/7161/barraut0.jpg

The yellow bar appear with my example but not with yours ... why?

HELP!

C.B.

tryanDLS
26 Dec 2006, 3:43 PM
That's not a popup, per se. That' IE security warning for a page referencing an ActiveXObject or even running javascript.

jack.slocum
26 Dec 2006, 4:46 PM
Are you running it from your local disk? If you are you will need to go into options and enable "Allow active content to run on files from my computer". IE7 disables JavaScript in local files (files from harddrive) by default.

crocobit
27 Dec 2006, 12:07 AM
Thanks a lot.
You solved my problem :lol:

C.B.